]> code.ossystems Code Review - openembedded-core.git/commitdiff
dbus: add reload action
authorRoss Burton <ross@openedhand.com>
Mon, 24 Sep 2007 15:16:43 +0000 (15:16 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 24 Sep 2007 15:16:43 +0000 (15:16 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2777 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/dbus/dbus-1.0.2/dbus-1.init
meta/packages/dbus/dbus_1.0.2.bb

index 88fe7e33db7f9e2d3e7c979f3b0f9d406041edef..0725083c690f2e9e27000c238f82029464469bef 100644 (file)
@@ -76,6 +76,16 @@ shut_it_down()
   rm -f $PIDFILE
 }
 
+reload_it()
+{
+  echo -n "Reloading $DESC config: "
+  dbus-send --print-reply --system --type=method_call \
+            --dest=org.freedesktop.DBus \
+            / org.freedesktop.DBus.ReloadConfig > /dev/null
+  # hopefully this is enough time for dbus to reload it's config file.
+  echo "done."
+}
+
 case "$1" in
   start)
     start_it_up
@@ -83,13 +93,16 @@ case "$1" in
   stop)
     shut_it_down
   ;;
-  restart|force-reload)
+  reload|force-reload)
+    reload_it
+  ;;
+  restart)
     shut_it_down
     sleep 1
     start_it_up
   ;;
   *)
-    echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+    echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
     exit 1
   ;;
 esac
index 0cfb4ebf46b00c212a783739151a9c1169f77879..7bf0a8634d513788bbddf24f34f0af8b185f9bb7 100644 (file)
@@ -6,7 +6,7 @@ DESCRIPTION = "message bus system for applications to talk to one another"
 LICENSE = "GPL"
 DEPENDS = "expat glib-2.0 virtual/libintl"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
           file://tmpdir.patch;patch=1 \