]> code.ossystems Code Review - openembedded-core.git/commitdiff
gconf: add gconftool-2 native wrapper
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Mon, 17 Dec 2012 12:32:42 +0000 (14:32 +0200)
committerSaul Wold <sgw@linux.intel.com>
Wed, 19 Dec 2012 07:48:22 +0000 (23:48 -0800)
This is needed when sstate cache is fetched from another build server.
In this case, the postinstall will fail because the backend libraries
path will be from the build server.

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/classes/gconf.bbclass
meta/recipes-gnome/gnome/gconf_3.2.3.bb

index 38097bc37a3d2609a5a20f497efa143bf2a12fe4..cc01bcad2ab7949340b27881e7ee2ef1134596a0 100644 (file)
@@ -15,7 +15,6 @@ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL = "1"
 
 gconf_postinst() {
 if [ "x$D" != "x" ]; then
-       export GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
        export GCONF_CONFIG_SOURCE="xml::$D${sysconfdir}/gconf/gconf.xml.defaults"
 else
        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
index f80c9104ed3c28ce6abdc36e24b22c983aa2fc38..ef21624de10e81a3068fbf98948e367fa14e01b9 100644 (file)
@@ -9,7 +9,7 @@ POLKIT_libc-uclibc = ""
 DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT} gobject-introspection-stub"
 DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
 
-PR = "r12"
+PR = "r13"
 
 inherit gnomebase gtk-doc
 
@@ -37,6 +37,11 @@ do_install_append() {
        rm -f ${D}${libdir}/gio/*/*.*a
 }
 
+do_install_append_class-native() {
+       create_wrapper ${D}/${bindir}/gconftool-2 \
+               GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
+}
+
 # disable dbus-x11 when x11 isn't in DISTRO_FEATURES
 RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
 RDEPENDS_${PN}_class-native = ""