]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: add slang to the dependencies
authorHenning Heinold <henning@itconsulting-heinold.de>
Mon, 16 Jun 2014 20:02:45 +0000 (22:02 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Jun 2014 07:58:14 +0000 (08:58 +0100)
* TUI/GUI support was added in 2.6.35 based on libnewt
* since 3.10 slang replaced libnewt completly
* changing TUI_DEFINES is not necessary, because NO_NEWT is
  still respected with newer kernels
* add comment about the gui history to the recipe

The patch was sponsored by sysmocom

Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 92d37e269ceb8f6dc008dbeb7e9005ad00e8bbea..20968f98ccf70e77bc55d3c0c8c3303d763f82c7 100644 (file)
@@ -15,7 +15,10 @@ require perf-features.inc
 
 BUILDPERF_libc-uclibc = "no"
 
-TUI_DEPENDS = "${@perf_feature_enabled('perf-tui', 'libnewt', '',d)}"
+# gui support was added with kernel 3.6.35
+# since 3.10 libnewt was replaced by slang
+# to cover a wide range of kernel we add both dependencies
+TUI_DEPENDS = "${@perf_feature_enabled('perf-tui', 'libnewt slang', '',d)}"
 SCRIPTING_DEPENDS = "${@perf_feature_enabled('perf-scripting', 'perl python', '',d)}"
 
 DEPENDS = "virtual/kernel \