]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr: avoid absolute paths for grep
authorJackie Huang <jackie.huang@windriver.com>
Mon, 8 Dec 2014 06:08:03 +0000 (01:08 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Dec 2014 10:17:45 +0000 (10:17 +0000)
The apr provides usr/share/build-1/libtool which is required by
the recipe such as apache2, and it will find grep on the host
and set absolute paths in libtool: GREP="/usr/bin/grep"

If we build apr/apr-native on a host that grep is in "/usr/bin/grep",
and re-use the sstate on another host with "/bin/grep", it will fail
when build apache2/apache2-native with:

| tmp/sysroots/x86_64-linux/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory
| tmp/sysroots/intel-x86-64/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory

(From OE-Core rev: 475709fc4f32e1ed01f45ee44819cd24e739eb43)

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-support/apr/apr_1.5.1.bb

index 49a08b026113337b63aa911add38ba6944214b11..a27b2338d10c01e6a7a8117fef004c2075ed41c9 100644 (file)
@@ -32,6 +32,11 @@ CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
 CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
 
 do_configure_prepend() {
+       # Avoid absolute paths for grep since it causes failures
+       # when using sstate between different hosts with different
+       # install paths for grep.
+       export GREP="grep"
+
        cd ${S}
        ./buildconf
 }