]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub-efi: specify prefix so it can find grub.cfg
authorDarren Hart <dvhart@linux.intel.com>
Fri, 16 Dec 2011 06:12:30 +0000 (22:12 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 16 Dec 2011 15:33:53 +0000 (15:33 +0000)
Specify /EFI/BOOT as the grub prefix so the grub efi payload can find
the grub.cfg in the same directory. Ultimately, it might make more sense
to install the grub tools and the grub-core modules to sysroot and make the
grub-efi bbclass generate the image in the required format as part of the
bootimg generation. However, bootimg is currently the only user, so make the
correction here to resolve the immediate issue.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub-efi-native_1.99.bb

index c86cf500828244a642be9f3281129bacab36aa48..9183812d5d5f1edaad5f2f9e7a20f41a2812f95d 100644 (file)
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 # FIXME: We should be able to optionally drop freetype as a dependency
 DEPENDS = "help2man-native"
 RDEPENDS_${PN} = "diffutils freetype"
-PR = "r1"
+PR = "r2"
 
 # Native packages do not normally rebuild when the target changes.
 # Ensure this is built once per HOST-TARGET pair.
@@ -58,7 +58,7 @@ EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
                 --target=${GRUB_TARGET} --enable-efiemu=no --program-prefix=''"
 
 do_mkimage() {
-       ./grub-mkimage -p / -d ./grub-core/ \
+       ./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \
                       -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
                       boot linux fat serial part_msdos normal efi_gop
 }