]> code.ossystems Code Review - openembedded-core.git/commitdiff
apt-native: remove db-native and curl-native dependencies
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 30 Jun 2008 13:32:23 +0000 (13:32 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 30 Jun 2008 13:32:23 +0000 (13:32 +0000)
idea from:
http://excogito.wordpress.com/2008/06/30/hacks-to-reduce-pokylinux-build-time/

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4747 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/apt/apt-native.inc
meta/packages/apt/apt-native_0.7.14.bb
meta/packages/apt/files/no-curl.patch [new file with mode: 0644]

index c3814842e0bb04861d04c690fe98484087802c9b..b3527e7361a13e3e9af45d291254b38154933b9b 100644 (file)
@@ -1,7 +1,7 @@
 require apt.inc
 inherit native
 
-DEPENDS += "dpkg-native curl-native db-native gettext-native"
+DEPENDS += "dpkg-native gettext-native"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}"
 PACKAGES = ""
 USE_NLS = "yes"
@@ -37,7 +37,6 @@ do_stage_base () {
        install -m 0755 bin/apt-get ${bindir}/
        install -m 0755 bin/apt-config ${bindir}/
        install -m 0755 bin/apt-cache ${bindir}/
-       install -m 0755 bin/apt-ftparchive ${bindir}/
        install -m 0755 bin/apt-sortpkgs ${bindir}/
        install -m 0755 bin/apt-extracttemplates ${bindir}/
 
index ef8decc748982362def70001bde6274b32514cfa..268e9df7208459dd0f29541d9ec2466a78e0dfeb 100644 (file)
@@ -1,6 +1,7 @@
 require apt-native.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI += "file://nodoc.patch;patch=1 \
-            file://noconfigure.patch;patch=1"
+            file://noconfigure.patch;patch=1 \
+           file://no-curl.patch;patch=1"
diff --git a/meta/packages/apt/files/no-curl.patch b/meta/packages/apt/files/no-curl.patch
new file mode 100644 (file)
index 0000000..4e07c8f
--- /dev/null
@@ -0,0 +1,44 @@
+---
+ configure.in     |    6 ------
+ methods/makefile |    7 -------
+ 2 files changed, 13 deletions(-)
+
+--- apt-0.7.14.orig/configure.in
++++ apt-0.7.14/configure.in
+@@ -84,16 +84,10 @@ AC_CHECK_HEADER(db.h,
+     )]
+ )
+ LIBS="$saveLIBS"
+-AC_CHECK_LIB(curl, curl_easy_init,
+-     [AC_CHECK_HEADER(curl/curl.h,
+-        curl_ok=yes,
+-        curl_ok=no)],
+-     AC_MSG_ERROR([failed: I need CURL due https support]),
+-)
+ AC_SUBST(BDBLIB)
+ dnl Converts the ARCH to be something singular for this general CPU family
+ dnl This is often the dpkg architecture string.
+--- apt-0.7.14.orig/methods/makefile
++++ apt-0.7.14/methods/makefile
+@@ -50,17 +50,10 @@ PROGRAM=http
+ SLIBS = -lapt-pkg $(SOCKETLIBS)
+ LIB_MAKES = apt-pkg/makefile
+ SOURCE = http.cc rfc2553emu.cc connect.cc
+ include $(PROGRAM_H)
+-# The https method
+-PROGRAM=https
+-SLIBS = -lapt-pkg -lcurl
+-LIB_MAKES = apt-pkg/makefile
+-SOURCE = https.cc
+-include $(PROGRAM_H)
+-
+ # The ftp method
+ PROGRAM=ftp
+ SLIBS = -lapt-pkg $(SOCKETLIBS)
+ LIB_MAKES = apt-pkg/makefile
+ SOURCE = ftp.cc rfc2553emu.cc connect.cc