]> code.ossystems Code Review - openembedded-core.git/commitdiff
piglit: add x11 to required DISTRO_FEATURES
authorMartin Jansa <martin.jansa@gmail.com>
Wed, 28 Jan 2015 14:52:11 +0000 (15:52 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 Feb 2015 14:53:42 +0000 (14:53 +0000)
* there is some pending work to resolve this unnecessary x11
  dependency, this can be reverted together with x11 dependency
  removal

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/piglit/piglit_git.bb

index f468120f80b3c468f4cee9d3467728fb2642a073..68ac7e76770606c2a1cf4406f5f5fc025e4c5613 100644 (file)
@@ -13,7 +13,9 @@ S = "${WORKDIR}/git"
 
 DEPENDS = "virtual/libx11 libxrender waffle virtual/libgl libglu python-mako-native python-numpy-native"
 
-inherit cmake pythonnative
+inherit cmake pythonnative distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 # As piglit doesn't install, enforce in-tree builds so that we can easily copy
 # contents out of $S and $B.