]> code.ossystems Code Review - openembedded-core.git/commitdiff
yum: fixed packaging
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 7 Oct 2008 09:31:18 +0000 (09:31 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 7 Oct 2008 09:31:18 +0000 (09:31 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5426 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/yum/files/fix [new file with mode: 0644]
meta/packages/yum/files/paths.patch
meta/packages/yum/files/paths2.patch [new file with mode: 0644]
meta/packages/yum/yum_3.2.18.bb

diff --git a/meta/packages/yum/files/fix b/meta/packages/yum/files/fix
new file mode 100644 (file)
index 0000000..bcb3301
--- /dev/null
@@ -0,0 +1,18 @@
+---
+ rpmUtils/Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- yum-3.2.18.orig/rpmUtils/Makefile
++++ yum-3.2.18/rpmUtils/Makefile
+@@ -1,10 +1,10 @@
+ PYTHON=python
+ PACKAGE = $(shell basename `pwd`)
+ PYFILES = $(wildcard *.py)
+ PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
+-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
++PYSYSDIR := /usr
+ PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
+ all: 
+       echo "Nothing to do"
index ee5c999c4b3f7bd38a595bab4da58c42bbabcfd2..55e6a0a2ee6c1f0692ecaf55a948af9739470346 100644 (file)
@@ -1,8 +1,14 @@
-Index: yum-3.2.18/Makefile
-===================================================================
---- yum-3.2.18.orig/Makefile   2008-08-23 09:13:56.000000000 +0100
-+++ yum-3.2.18/Makefile        2008-08-23 09:18:09.000000000 +0100
-@@ -18,19 +18,19 @@
+---
+ Makefile      |   18 +++++++++---------
+ docs/Makefile |   12 ++++++------
+ etc/Makefile  |   20 ++++++++++----------
+ 3 files changed, 25 insertions(+), 25 deletions(-)
+
+--- yum-3.2.18.orig/Makefile
++++ yum-3.2.18/Makefile
+@@ -16,23 +16,23 @@ clean:
+ subdirs:
        for d in $(SUBDIRS); do make PYTHON=$(PYTHON) -C $$d; [ $$? = 0 ] || exit 1 ; done
  
  install:
@@ -27,15 +33,17 @@ Index: yum-3.2.18/Makefile
 -      mkdir -p $(DESTDIR)/var/cache/yum
 -      mkdir -p $(DESTDIR)/var/lib/yum 
 +      mkdir -p $(DESTDIR)$(localstatedir)/cache/yum
-+      mkdir -p $(DESTDIR)$(localstatedir)/lib/yum     
++      mkdir -p $(DESTDIR)$(localstatedir)/lib/yum
  
        for d in $(SUBDIRS); do make PYTHON=$(PYTHON) DESTDIR=`cd $(DESTDIR); pwd` -C $$d install; [ $$? = 0 ] || exit 1; done
  
-Index: yum-3.2.18/docs/Makefile
-===================================================================
---- yum-3.2.18.orig/docs/Makefile      2008-08-23 09:19:07.000000000 +0100
-+++ yum-3.2.18/docs/Makefile   2008-08-23 09:19:37.000000000 +0100
-@@ -6,9 +6,9 @@
+ .PHONY: docs test
+--- yum-3.2.18.orig/docs/Makefile
++++ yum-3.2.18/docs/Makefile
+@@ -4,11 +4,11 @@ all:
+ clean:
+       rm -f *.pyc *.pyo *~
        rm -fr epydoc
  
  install:
@@ -51,11 +59,11 @@ Index: yum-3.2.18/docs/Makefile
 +      install -m 644 yum.conf.5 $(DESTDIR)$(mandir)/man5/yum.conf.5
 +      install -m 644 yum-updatesd.8 $(DESTDIR)$(mandir)/man8/yum-updatesd.8
 +      install -m 644 yum-updatesd.conf.5 $(DESTDIR)$(mandir)/man5/yum-updatesd.conf.5
-Index: yum-3.2.18/etc/Makefile
-===================================================================
---- yum-3.2.18.orig/etc/Makefile       2008-08-23 09:19:51.000000000 +0100
-+++ yum-3.2.18/etc/Makefile    2008-08-23 09:20:28.000000000 +0100
-@@ -5,20 +5,20 @@
+--- yum-3.2.18.orig/etc/Makefile
++++ yum-3.2.18/etc/Makefile
+@@ -3,22 +3,22 @@ all:
+ clean:
        rm -f *.pyc *.pyo *~
  
  install:
diff --git a/meta/packages/yum/files/paths2.patch b/meta/packages/yum/files/paths2.patch
new file mode 100644 (file)
index 0000000..08c9c83
--- /dev/null
@@ -0,0 +1,33 @@
+---
+ rpmUtils/Makefile |    2 +-
+ yum/Makefile      |    2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- yum-3.2.18.orig/rpmUtils/Makefile
++++ yum-3.2.18/rpmUtils/Makefile
+@@ -1,10 +1,10 @@
+ PYTHON=python
+ PACKAGE = $(shell basename `pwd`)
+ PYFILES = $(wildcard *.py)
+ PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
+-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
++PYSYSDIR = /usr
+ PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
+ all: 
+       echo "Nothing to do"
+--- yum-3.2.18.orig/yum/Makefile
++++ yum-3.2.18/yum/Makefile
+@@ -1,10 +1,10 @@
+ PYTHON=python
+ PACKAGE = $(shell basename `pwd`)
+ PYFILES = $(wildcard *.py)
+ PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
+-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
++PYSYSDIR = /usr
+ PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
+ all: 
+       echo "Nothing to do"
index 9770a4e6888263452bd287b5a6a1ac2f6ddf9589..4c68803098d570cc5cc92ad3babce7e2979b6a02 100644 (file)
@@ -1,12 +1,14 @@
 HOMEPAGE = "http://linux.duke.edu/projects/yum/"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
            file://paths.patch;patch=1 \
+           file://paths2.patch;patch=1 \
           file://yum-install-recommends.py \
           file://extract-postinst.awk"
 
-DEPENDS = "rpm python python-iniparse python-urlgrabber yum-metadata-parser libxml2"
+DEPENDS = "python"
+RDEPENDS = "rpm python-core python-iniparse python-urlgrabber yum-metadata-parser"
 
 S = "${WORKDIR}/yum-${PV}"
 
@@ -22,3 +24,5 @@ do_install_append () {
        install ${WORKDIR}/extract-postinst.awk ${D}${bindir}/
        install ${WORKDIR}/yum-install-recommends.py ${D}${bindir}/
 }
+
+FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli"