]> code.ossystems Code Review - openembedded-core.git/commitdiff
dpkg: rm rcS.d/S98configure to not run it on non-first boot
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 3 Jul 2008 10:46:27 +0000 (10:46 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 3 Jul 2008 10:46:27 +0000 (10:46 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4795 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/dpkg/dpkg.inc
meta/packages/dpkg/dpkg_1.14.19.bb

index 1a8e7ec9aab66c2a56bb75f2a9e89857505e9c22..041b437abdd576e3c619802f36f3a038667df2af 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Package maintenance system for Debian."
 LICENSE = "GPL"
 SECTION = "base"
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz \
            file://ignore_extra_fields.patch;patch=1 \
@@ -23,6 +23,7 @@ if [ "x$D" != "x" ]; then
        # this happens at S98 where our good 'ole packages script used to run
        echo -e "#!/bin/sh
        dpkg --configure -a
+       rm -f /${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
 " > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
        chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
 fi
index b1f84fadf5c5ec69aea529e21fba1b32db86cb7f..1a7991d40e50ee151aa871972ee07c70b2f8c879 100644 (file)
@@ -1,6 +1,7 @@
 require dpkg.inc
 DEPENDS += "zlib bzip2"
 RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
+
 SRC_URI += "file://noman.patch;patch=1"
 
 EXTRA_OECONF = "--without-static-progs \