]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: Added option to enable http2 protocol.
authorbaali <shantanu@senic.com>
Mon, 25 Sep 2017 19:20:34 +0000 (00:50 +0530)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Sep 2017 09:14:17 +0000 (10:14 +0100)
With default --without-nghttp2 flag set there was no way to get
http2 protocol support using nghttp2 library. Instead moved it to
PACKAGECONFIG options

Signed-off-by: baali <shantanu@senic.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/curl/curl_7.54.1.bb

index 54f3b667c8a7bf637ccc067319a78ba140660e0b..04aeee72d1513b5eaa5da557619366e0cec06cee 100644 (file)
@@ -48,13 +48,13 @@ PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
 PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver"
 PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
 PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
+PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
 
 EXTRA_OECONF = " \
     --enable-crypto-auth \
     --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
     --without-libmetalink \
     --without-libpsl \
-    --without-nghttp2 \
 "
 
 do_install_append() {