]> code.ossystems Code Review - openembedded-core.git/commitdiff
tcl: fix race in interp.test
authorRoss Burton <ross.burton@arm.com>
Mon, 12 Jul 2021 13:50:13 +0000 (14:50 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Jul 2021 13:24:48 +0000 (14:24 +0100)
There's a timeout race in interp which is exposed when running under load.

Signed-off-by: Ross Burton <ross.burton@arm.com>
meta/recipes-devtools/tcltk/tcl/interp.patch [new file with mode: 0644]
meta/recipes-devtools/tcltk/tcl_8.6.11.bb

diff --git a/meta/recipes-devtools/tcltk/tcl/interp.patch b/meta/recipes-devtools/tcltk/tcl/interp.patch
new file mode 100644 (file)
index 0000000..95d6318
--- /dev/null
@@ -0,0 +1,32 @@
+The interp-36.7 patch has race conditions and is missing cleanup.  This patch by
+a Tcl maintainer should improve matters.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+diff --git a/tests/interp.test b/tests/interp.test
+index d7424847f..fc90990f3 100644
+--- a/tests/interp.test
++++ b/tests/interp.test
+@@ -3595,17 +3595,18 @@ test interp-36.7 {ChildBgerror sets error handler of child [1999035]} -setup {
+         variable result
+         set result [lindex $args 0]
+     }
++    set tout [after 5000 {set result timeout}]
+ } -body {
+     child eval {
+         variable done {}
+         after 0 error foo
+-        after 10 [list ::set [namespace which -variable done] {}]
+-        vwait [namespace which -variable done]
+     }
++    vwait result
+     set result
+ } -cleanup {
++    after cancel $tout
+     variable result {}
+-    unset -nocomplain result
++    unset -nocomplain result tout
+     interp delete child
+ } -result foo
index 0d7c2e4ac34e9b7a9279eca68b4bede111fbdd65..57a86e4c6488cdd6a0866d4978e0476fce7aaa7c 100644 (file)
@@ -22,6 +22,7 @@ SRC_URI = "${BASE_SRC_URI} \
            file://fix_issue_with_old_distro_glibc.patch \
            file://tcl-remove-hardcoded-install-path.patch \
            file://alter-includedir.patch \
+           file://interp.patch \
            file://run-ptest \
 "
 SRC_URI[sha256sum] = "cfb49aab82bd179651e23eeeb69606f51b0ddc575ca55c3d35e2457469024cfa"