]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Fix linking error encountered in rpm-native
authorKhem Raj <raj.khem@gmail.com>
Thu, 3 Mar 2011 16:09:06 +0000 (08:09 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Mar 2011 23:30:32 +0000 (23:30 +0000)
* This patch passes the correct LDFLAGS to account for
  additional dependencies of librpmio on libbeecrypt and libsyck
  and hence fixes the build error.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch [new file with mode: 0644]
meta/recipes-devtools/rpm/rpm_5.4.0.bb

diff --git a/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch b/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
new file mode 100644 (file)
index 0000000..9e7bba0
--- /dev/null
@@ -0,0 +1,24 @@
+Source: None
+Status: Needs to go Upstream
+Author: Khem Raj <raj.khem@gmail.com>
+Date: 2011-03-03
+Description:
+This patch fixes build issue found when compiling rpm-natibe on ubuntu
+11.04-alpha. Problem is that linker does not get correct set of dependent
+libraries when linking mtree binary which results in undefined symbols
+in librpmio.so. This patch adds correct flags to mtree_LDADD to account
+for rpmio deps
+
+Index: rpm-5.4.0/tools/Makefile.am
+===================================================================
+--- rpm-5.4.0.orig/tools/Makefile.am
++++ rpm-5.4.0/tools/Makefile.am
+@@ -169,7 +169,7 @@ grep_LDADD =               $(RPMIO_LDADD_COMMON)
+ mtree_SOURCES =               rpmmtree.c
+ mtree_LDFLAGS =               @LDFLAGS_STATIC@ $(LDFLAGS)
+-mtree_LDADD =         $(RPM_LDADD_COMMON)
++mtree_LDADD =         $(RPMIO_LDADD_COMMON)
+ rpmrepo_SOURCES =     rpmrepo.c
+ rpmrepo_CPPFLAGS =    $(AM_CPPFLAGS) -I$(top_srcdir)/scripts -I$(top_builddir)/scripts $(CPPFLAGS)
index 0003f48e106c03fceff8c8564b613665a149b9f4..370481647a4ab308f8b57df5a89e55975615a7a7 100644 (file)
@@ -43,7 +43,7 @@ LICENSE = "LGPL 2.1"
 LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
 DEPENDS = "bzip2 zlib python perl db openssl elfutils expat libpcre attr acl popt"
-PR = "r13"
+PR = "r14"
 
 # rpm2cpio is a shell script, which is part of the rpm src.rpm.  It is needed
 # in order to extract the distribution SRPM into a format we can extract...
@@ -56,6 +56,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.0-0.20101229.src.rpm;ex
           file://rpm-showrc.patch \
           file://rpm-nofsync.patch \
           file://rpm-solvedb.patch \
+          file://rpm-tools-mtree-LDFLAGS.patch \
          "
 
 #           file://hdraddorappend.patch \