]> code.ossystems Code Review - openembedded-core.git/commitdiff
avahi: add LICENSE for individual packages
authorMatthew <matthew.zeng@windriver.com>
Fri, 27 Mar 2020 16:43:18 +0000 (12:43 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 29 Mar 2020 19:03:31 +0000 (20:03 +0100)
Fixes [YOCTO #13609]

avahi_0.7.bb defines 9 PACKAGES. However, avahi.inc generically sets
LICENSE to "GPLv2+ & LGPLv2.1+". The library specific
packages should be LGPLv2.1+ only.

Signed-off-by: Matthew Zeng <matthew.zeng@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/avahi/avahi_0.7.bb

index 2e04d304c7ec545ea0f9f05345e2d9a202f2322f..24523c7f813c68de80fbb12da0596e05c2406796 100644 (file)
@@ -10,6 +10,16 @@ inherit update-rc.d systemd useradd
 
 PACKAGES =+ "libavahi-gobject avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils"
 
+LICENSE_libavahi-gobject = "LGPLv2.1+"
+LICENSE_avahi-daemon = "LGPLv2.1+"
+LICENSE_libavahi-common = "LGPLv2.1+"
+LICENSE_libavahi-core = "LGPLv2.1+"
+LICENSE_avahi-client = "LGPLv2.1+"
+LICENSE_avahi-dnsconfd = "LGPLv2.1+"
+LICENSE_libavahi-glib = "LGPLv2.1+"
+LICENSE_avahi-autoipd = "LGPLv2.1+"
+LICENSE_avahi-utils = "LGPLv2.1+"
+
 # As avahi doesn't put any files into PN, clear the files list to avoid problems
 # if extra libraries appear.
 FILES_${PN} = ""