]> code.ossystems Code Review - openembedded-core.git/commitdiff
expect: Fix configure error for nativesdk
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 26 Sep 2019 02:51:43 +0000 (10:51 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 27 Sep 2019 12:01:17 +0000 (13:01 +0100)
Fixed:
$ bitbake nativesdk-expect
checking for Tcl public headers... configure: error: tcl.h not found.  Please specify its location with --with-tclinclude

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/expect/expect_5.45.4.bb

index 96eacd929347efc8cc69eb8220c02be938cef720..5f59083ad28f44d1535157449aa7529a745ab905 100644 (file)
@@ -44,9 +44,9 @@ do_install_append() {
 }
 
 # Apparently the public Tcl headers are only in /usr/include/tcl8.6
-# when building for the target.
-TCL_INCLUDE_PATH = ""
-TCL_INCLUDE_PATH_class-target = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
+# when building for the target and nativesdk.
+TCL_INCLUDE_PATH = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
+TCL_INCLUDE_PATH_class-native = ""
 
 EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
                  --enable-shared \