]> code.ossystems Code Review - openembedded-core.git/commitdiff
libopensync: added check to dependencies and patch to get rid of Python
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 18 Jun 2008 08:36:46 +0000 (08:36 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 18 Jun 2008 08:36:46 +0000 (08:36 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4693 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/opensync/libopensync-0.36/no-python-check.patch [new file with mode: 0644]
meta/packages/opensync/libopensync_0.36.bb

diff --git a/meta/packages/opensync/libopensync-0.36/no-python-check.patch b/meta/packages/opensync/libopensync-0.36/no-python-check.patch
new file mode 100644 (file)
index 0000000..08a53cb
--- /dev/null
@@ -0,0 +1,18 @@
+---
+ CMakeLists.txt |    1 -
+ 1 file changed, 1 deletion(-)
+
+--- libopensync-0.36.orig/CMakeLists.txt
++++ libopensync-0.36/CMakeLists.txt
+@@ -26,11 +26,10 @@ INCLUDE_DIRECTORIES( ${CMAKE_CURRENT_BIN
+ FIND_PACKAGE( GLIB2 REQUIRED )
+ FIND_PACKAGE( Sqlite3 REQUIRED )
+ FIND_PACKAGE( LibXml2 REQUIRED )
+ FIND_PACKAGE( SWIG )  
+-FIND_PACKAGE( PythonLibs )
+ FIND_PACKAGE( Check )
+ ADD_SUBDIRECTORY( opensync )
+ ADD_SUBDIRECTORY( formats )
+ ADD_SUBDIRECTORY( tools )
index 9fad1b3031ee32816680f00f8d4183b7cc0f5519..f41cf89b5f6008440a81a8ced8af958e3b24ca7e 100644 (file)
@@ -1,11 +1,12 @@
 LICENSE = "LGPL"
 HOMEPAGE = "http://www.opensync.org/"
 
-DEPENDS = "sqlite3 libxml2 glib-2.0"
+DEPENDS = "sqlite3 libxml2 glib-2.0 check"
 
 SRC_URI = "http://opensync.org/download/releases/${PV}/libopensync-${PV}.tar.bz2\
            file://cmake.patch;patch=1 \
-          file://build-in-src.patch;patch=1"
+          file://build-in-src.patch;patch=1 \
+          file://no-python-check.patch;patch=1"
 
 inherit cmake pkgconfig