]> code.ossystems Code Review - openembedded-core.git/commitdiff
setuptools_build_meta: remove python dependency
authorKonrad Weihmann <kweihmann@outlook.com>
Sat, 5 Mar 2022 11:16:58 +0000 (12:16 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 5 Mar 2022 22:57:45 +0000 (22:57 +0000)
when building additional native python tools that should be used
for additional tasks in python3 package (class-target), the dependency
on target class python creates a dependency loop:

python3-foo-native_1.2.3.bb:do_prepare_recipe_sysroot
python3-pep8-native_1.7.1.bb:do_populate_sysroot
python3-wheel_0.37.1.bb:do_populate_sysroot
python3-bar-native_0.1.2.bb:do_populate_sysroot
python3-pip_22.0.3.bb:do_populate_sysroot
python3-pyflakes-native_2.4.0.bb:do_populate_sysroot
python3_3.10.2.bb:do_populate_sysroot
python3-foo-native_1.2.3_1.2.0.bb:do_fetch
python3-setuptools_59.5.0.bb:do_populate_sysroot

resolve this by removing python3 from DEPENDS.
The correct dependencies are already injected by
setuptools-base class

Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/setuptools_build_meta.bbclass

index b1441e65dd5943f9f95f4cc7206730a10b324681..8f5479e922d251674578072c7ebe6aeabb2f9323 100644 (file)
@@ -1,6 +1,6 @@
 inherit pip_install_wheel setuptools3-base
 
-DEPENDS += "python3 python3-setuptools-native python3-wheel-native"
+DEPENDS += "python3-setuptools-native python3-wheel-native"
 
 setuptools_build_meta_do_configure () {
     mkdir -p ${S}/dist