]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipetool.newappend: fix syntax error for 'not path_ok' error
authorChristopher Larson <chris_larson@mentor.com>
Thu, 21 Apr 2016 15:45:41 +0000 (08:45 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Apr 2016 06:34:11 +0000 (07:34 +0100)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
scripts/lib/recipetool/newappend.py

index bdf0693ec7b17cf945f0b92b7da64ba95979c9aa..4fbb40a35897698d1b60993b50e090a7b411fc17 100644 (file)
@@ -81,7 +81,7 @@ def newappend(args):
         return 1
 
     if not path_ok:
-        logger.warn('Unable to determine correct subdirectory path for bbappend file - check that what %s adds to BBFILES also matches .bbappend files. Using %s for now, but until you fix this the bbappend will not be applied.', os.path.join(destlayerdir, 'conf', 'layer.conf'), os.path.dirname(appendpath))
+        logger.warn('Unable to determine correct subdirectory path for bbappend file - check that what %s adds to BBFILES also matches .bbappend files. Using %s for now, but until you fix this the bbappend will not be applied.', os.path.join(args.destlayer, 'conf', 'layer.conf'), os.path.dirname(append_path))
 
     layerdirs = [os.path.abspath(layerdir) for layerdir in rd.getVar('BBLAYERS', True).split()]
     if not os.path.abspath(args.destlayer) in layerdirs: