]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-native: Remove debug.patch
authorMax Tomago <max.tomago@codethink.co.uk>
Tue, 15 Oct 2019 16:37:44 +0000 (17:37 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 19 Oct 2019 22:18:26 +0000 (23:18 +0100)
It doesn't look like it should be there.

Signed-off-by: Max Tomago <max.tomago@codethink.co.uk>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-native/debug.patch [deleted file]
meta/recipes-devtools/python/python-native_2.7.16.bb

diff --git a/meta/recipes-devtools/python/python-native/debug.patch b/meta/recipes-devtools/python/python-native/debug.patch
deleted file mode 100644 (file)
index 3617882..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-Upstream-Status: Pending
-
-Index: Python-2.7.12/Lib/distutils/unixccompiler.py
-===================================================================
---- Python-2.7.12.orig/Lib/distutils/unixccompiler.py
-+++ Python-2.7.12/Lib/distutils/unixccompiler.py
-@@ -278,6 +278,8 @@ class UnixCCompiler(CCompiler):
-+        print "Looking in %s for %s" % (lib, dirs)
-+
-         for dir in dirs:
-             shared = os.path.join(dir, shared_f)
-             dylib = os.path.join(dir, dylib_f)
-@@ -298,12 +300,16 @@ class UnixCCompiler(CCompiler):
-             # assuming that *all* Unix C compilers do.  And of course I'm
-             # ignoring even GCC's "-static" option.  So sue me.
-             if os.path.exists(dylib):
-+                print "Found %s" % (dylib)
-                 return dylib
-             elif os.path.exists(xcode_stub):
-+                print "Found %s" % (xcode_stub)
-                 return xcode_stub
-             elif os.path.exists(shared):
-+                print "Found %s" % (shared)
-                 return shared
-             elif os.path.exists(static):
-+                print "Found %s" % (static)
-                 return static
-         # Oops, didn't find it in *any* of 'dirs'
index b7442800d9826424551f460e964bbffa4d5022df..90103af8be51ac2ec2bd8f569668ad02979bfc4c 100644 (file)
@@ -7,7 +7,6 @@ SRC_URI += "\
             file://10-distutils-fix-swig-parameter.patch \
             file://11-distutils-never-modify-shebang-line.patch \
             file://0001-distutils-set-the-prefix-to-be-inside-staging-direct.patch \
-            file://debug.patch \
             file://unixccompiler.patch \
             file://nohostlibs.patch \
             file://multilib.patch \