]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: add dependency headers
authorRoss Burton <ross@openedhand.com>
Thu, 3 Jul 2008 15:20:56 +0000 (15:20 +0000)
committerRoss Burton <ross@openedhand.com>
Thu, 3 Jul 2008 15:20:56 +0000 (15:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4801 311d38ba-8fff-0310-9ca6-ca027cbcb966

20 files changed:
meta/packages/initscripts/initscripts-1.0/arm/alignment.sh
meta/packages/initscripts/initscripts-1.0/banner.sh
meta/packages/initscripts/initscripts-1.0/bootmisc.sh
meta/packages/initscripts/initscripts-1.0/checkfs.sh
meta/packages/initscripts/initscripts-1.0/checkroot.sh
meta/packages/initscripts/initscripts-1.0/finish.sh
meta/packages/initscripts/initscripts-1.0/halt
meta/packages/initscripts/initscripts-1.0/hostname.sh
meta/packages/initscripts/initscripts-1.0/mountall.sh
meta/packages/initscripts/initscripts-1.0/mountnfs.sh
meta/packages/initscripts/initscripts-1.0/populate-volatile.sh
meta/packages/initscripts/initscripts-1.0/reboot
meta/packages/initscripts/initscripts-1.0/rmnologin
meta/packages/initscripts/initscripts-1.0/sendsigs
meta/packages/initscripts/initscripts-1.0/single
meta/packages/initscripts/initscripts-1.0/sysfs.sh
meta/packages/initscripts/initscripts-1.0/umountfs
meta/packages/initscripts/initscripts-1.0/umountnfs.sh
meta/packages/initscripts/initscripts-1.0/urandom
meta/packages/initscripts/initscripts_1.0.bb

index 4a66dc6bc8ede1963a81ed77b889a42f2370e699..b577b9a03a26d9bab794b09662840739331e7d36 100644 (file)
@@ -1,4 +1,11 @@
 #!/bin/sh
+### BEGIN INIT INFO
+# Provides: alignment
+# Required-Start:    mountkernfs
+# Required-Stop:     mountkernfs
+# Default-Start:     S
+# Default-Stop:
+### END INIT INFO
 
 if [ -e /proc/cpu/alignment ]; then
    echo "3" > /proc/cpu/alignment
index 0349ce195458bbb84a086269b944c13215389438..9e2b09125282165d434818ea35a8f2420e8b3e0a 100644 (file)
@@ -1,4 +1,11 @@
 #!/bin/sh
+### BEGIN INIT INFO
+# Provides: banner
+# Required-Start:
+# Required-Stop:
+# Default-Start:     S
+# Default-Stop:
+### END INIT INFO
 
 if [ ! -e /dev/tty ]; then
     /bin/mknod -m 0666 /dev/tty c 5 0
index d67346b8867a1d49e4aa9e11d4804dabe9097f8a..f8e1dd65781c35f2a6b90d3927257db1e6c9a9fc 100755 (executable)
@@ -1,6 +1,11 @@
-#
-# bootmisc.sh  Miscellaneous things to be done during bootup.
-#
+### BEGIN INIT INFO
+# Provides:          bootmisc
+# Required-Start:    $local_fs mountvirtfs
+# Required-Stop:     $local_fs
+# Default-Start:     S
+# Default-Stop:      0 6
+# Short-Description: Misc and other.
+### END INIT INFO
 
 . /etc/default/rcS
 #
index 7d2d75ef577ec86524a9dd9d4384f5fac53352d7..91897d4cbb0550cae5b5d3783788c6840ae60edb 100755 (executable)
@@ -1,8 +1,11 @@
-#
-# checkfs.sh   Check all filesystems.
-#
-# Version:     @(#)checkfs  2.83  05-Oct-2001  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          checkfs
+# Required-Start:    checkroot
+# Required-Stop:     
+# Default-Start:     S
+# Default-Stop:
+# Short-Description: Check all other file systems
+### END INIT INFO
 
 . /etc/default/rcS
 
index 215b6de0ade7b60aa3064fbc8dd7a2e4d15b0902..8226f543dd1218a80bebe57208d4cc40568ef1b8 100755 (executable)
@@ -1,6 +1,6 @@
 ### BEGIN INIT INFO
 # Provides:          checkroot
-# Required-Start:    udev sysfs
+# Required-Start:    udev
 # Required-Stop:     
 # Default-Start:     S
 # Default-Stop:
index 4f9f75f47c8439267b8e051d73d30618df86a44a..63b6baa2f777e0b91aa31e7054a64b9042f31119 100755 (executable)
@@ -3,4 +3,3 @@
 if ! test -e /etc/.configured; then
        > /etc/.configured
 fi
-
index d8cab222ca01feee54d32b5c014016b3ced10299..f76c72177beb3f103425f8e4e4921eb30ab3c1fc 100755 (executable)
@@ -1,9 +1,14 @@
 #! /bin/sh
-#
-# halt         Execute the halt command.
-#
-# Version:      @(#)halt  2.84-2  07-Jan-2002  miquels@cistron.nl
-#
+###
+# BEGIN INIT INFO
+# Provides:          halt
+# Required-Start:
+# Required-Stop:
+# Default-Start:
+# Default-Stop:      0
+# Short-Description: Execute the halt command.
+# Description:
+### END INIT INFO
 
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 
index 0f3d3742864d662192c5d578d46e58e76e322fe4..4399ee7b18f993e414a60393fc3af74fe5a8fb6f 100755 (executable)
@@ -1,11 +1,13 @@
-#
-# hostname.sh  Set hostname.
-#
-# Version:     @(#)hostname.sh  1.10  26-Feb-2001  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          hostname
+# Required-Start:
+# Required-Stop:
+# Default-Start:     S
+# Default-Stop:
+# Short-Description: Set hostname based on /etc/hostname
+### END INIT INFO
 
 if test -f /etc/hostname
 then
        hostname -F /etc/hostname
 fi
-
index 84227a5fe377d709ab4b655acf34f224f5fa86a1..9d4f97b68351e8cdbbc3bf395f0207c03964f5c5 100755 (executable)
@@ -1,8 +1,13 @@
-#
-# mountall.sh  Mount all filesystems.
-#
-# Version:     @(#)mountall.sh  2.83-2  01-Nov-2001  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          mountall
+# Required-Start:    mountvirtfs
+# Required-Stop: 
+# Default-Start:     S
+# Default-Stop:
+# Short-Description: Mount all filesystems.
+# Description:
+### END INIT INFO
+
 . /etc/default/rcS
 
 #
index 84cb3651fc593efd4291af9af708849338c13da3..46c58b16a88e65f43da9cbfe584f246e23218eed 100755 (executable)
@@ -1,14 +1,10 @@
-#
-# mountnfs.sh  Now that TCP/IP is configured, mount the NFS file
-#              systems in /etc/fstab if needed. If possible,
-#              start the portmapper before mounting (this is needed for
-#              Linux 2.1.x and up).
-#
-#              Also mounts SBM filesystems now, so the name of
-#              this script is getting increasingly inaccurate.
-#
-# Version:     @(#)mountnfs.sh  2.83  05-Oct-2001  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          mountnfs
+# Required-Start:    $local_fs $network $portmap
+# Required-Stop:
+# Default-Start:     S
+# Default-Stop:
+### END INIT INFO
 
 . /etc/default/rcS
 
index 3bb3d94de64348c67cf143b86489fdef2413dfc2..8be0b10a6a26961618d386247cf083185c4eed59 100755 (executable)
@@ -1,4 +1,12 @@
 #!/bin/sh
+### BEGIN INIT INFO
+# Provides:             volatile
+# Required-Start:       $local_fs
+# Required-Stop:      $local_fs
+# Default-Start:        S
+# Default-Stop:
+# Short-Description:  Populate the volatile filesystem
+### END INIT INFO
 
 . /etc/default/rcS
 
index 56278199be49b494017f9458d2a81cf7795738f9..4c55885abafcfb29aaf42d54dd10cc897aac3d69 100755 (executable)
@@ -1,9 +1,13 @@
 #! /bin/sh
-#
-# reboot       Execute the reboot command.
-#
-# Version:      @(#)reboot  2.75  22-Jun-1998  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          reboot
+# Required-Start:
+# Required-Stop:
+# Default-Start:
+# Default-Stop:      6
+# Short-Description: Execute the reboot command.
+# Description:
+### END INIT INFO
 
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 
index 444145a26a2080091e258009ea6ef407605f094b..417efc24560cf0918149b64cf6c7177b8c682653 100755 (executable)
@@ -1,10 +1,16 @@
 #! /bin/sh
-#
-# rmnologin    This script removes the /etc/nologin file as the last
-#              step in the boot process.
-#
-# Version:     @(#)rmnologin  1.00  22-Jun-1998  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          rmnologin
+# Required-Start:    $remote_fs $all
+# Required-Stop: 
+# Default-Start:     2 3 4 5
+# Default-Stop:
+# Short-Description: Remove /etc/nologin at boot
+# Description:       This script removes the /etc/nologin file as the
+#                    last step in the boot process, if DELAYLOGIN=yes.
+#                    If DELAYLOGIN=no, /etc/nologin was not created by
+#                    bootmisc earlier in the boot process.
+### END INIT INFO
 
 if test -f /etc/nologin.boot
 then
index c62a5cd37df4397d999f82a4f630892df73f4c2a..2b0f8f36318b767ccdbd7988d00b80544fcf21cd 100755 (executable)
@@ -1,9 +1,13 @@
 #! /bin/sh
-#
-# sendsigs     Kill all remaining processes.
-#
-# Version:      @(#)sendsigs  2.75  22-Jun-1998  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          sendsigs
+# Required-Start:    
+# Required-Stop:     umountnfs
+# Default-Start:
+# Default-Stop:      0 6
+# Short-Description: Kill all remaining processes.
+# Description: 
+### END INIT INFO
 
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 
index 2d177ebb62a0bc496d076f51aed39a50beafdda1..0cad693f209a674b883ffcc2d480cb40348200e9 100755 (executable)
@@ -1,9 +1,12 @@
 #! /bin/sh
-#
-# single       executed by init(8) upon entering runlevel 1 (single).
-#
-# Version:     @(#)single  1.20  26-Geb-2001  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          single
+# Required-Start:    $local_fs $all killprocs
+# Required-Stop:
+# Default-Start:     1
+# Default-Stop:
+# Short-Description: executed by init(8) upon entering runlevel 1 (single).
+### END INIT INFO
 
 PATH="/sbin:/bin:/usr/sbin:/usr/bin"
 
index f779a6e88106f0ec199648743b0ab836ff179e65..be28bb35bfd918b5a222d045ef4aa2a8fd9d1c4f 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 ### BEGIN INIT INFO
-# Provides:          sysfs
+# Provides:          mountvirtfs
 # Required-Start:
 # Required-Stop:
 # Default-Start:     S
index ec75b0c4a4c745ef824ad0e61cbbc0875eb9c18b..5c6793dc9cfd574f4967ea599c8bc53e166e1ee2 100755 (executable)
@@ -1,7 +1,13 @@
 #! /bin/sh
-#
-# umountfs     Turn off swap and unmount all local filesystems.
-#
+### BEGIN INIT INFO
+# Provides:          umountfs
+# Required-Start:
+# Required-Stop:     
+# Default-Start:
+# Default-Stop:      0 6
+# Short-Description: Turn off swap and unmount all local file systems.
+# Description:
+### END INIT INFO
 
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 
index f5fe48aa7481d02ff19f5c64497f39dadaeba62e..a4fb821d9117b694384d8cd8a21a7d099781aeb4 100755 (executable)
@@ -1,7 +1,12 @@
-#! /bin/sh
-#
-# umountnfs.sh Unmount all network filesystems.
-#
+### BEGIN INIT INFO
+# Provides:          umountnfs
+# Required-Start:
+# Required-Stop:     umountfs
+# Should-Stop:       $network $portmap
+# Default-Start:
+# Default-Stop:      0 6
+# Short-Description: Unmount all network filesystems
+### END INIT INFO
 
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 
@@ -25,4 +30,3 @@ done
 ) < /etc/fstab
 
 : exit 0
-
index 45c41d758b5840b8ff7b0f120313376b387ed563..b6d807cf3b8784057ea9e79c8dada1b2f6d6ffe0 100755 (executable)
@@ -1,10 +1,15 @@
 #! /bin/sh
-#
-# urandom      This script saves the random seed between reboots.
-#              It is called from the boot, halt and reboot scripts.
-#
-# Version:     @(#)urandom  1.33  22-Jun-1998  miquels@cistron.nl
-#
+### BEGIN INIT INFO
+# Provides:          urandom
+# Required-Start:    $local_fs mountvirtfs
+# Required-Stop:     $local_fs
+# Default-Start:     S
+# Default-Stop:      0 6
+# Short-Description: Save and restore the random seed
+# Description:       Save the random seed on shutdown and restore it on boot,
+#                    to ensure that the seed isn't predicable on startup
+#                    (because the boot process is predictable)
+### END INIT INFO
 
 test -c /dev/urandom || exit 0
 . /etc/default/rcS
index 9e8c8aa9ca2c709bebffa5a0b299a662b110f993..abaecefc48ff01ad80f5e0d711361408a0881c6b 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r111"
+PR = "r113"
 
 SRC_URI = "file://functions \
            file://halt \