]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpcap: Disable DPDK explicitly
authorSean Anderson <sean.anderson@seco.com>
Thu, 10 Feb 2022 20:49:19 +0000 (15:49 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 12 Feb 2022 17:05:30 +0000 (17:05 +0000)
libpcap looks for DPDK in the same way it looks for DAG. This can poison
the build even if it doesn't find anything. Explicitly disable dpdk.

Signed-off-by: Sean Anderson <sean.anderson@seco.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb

index 9a8c46e0ef58dd92be5e279771d89ab6bdb4c85b..dbe2fd8157cad73771578c8b1428bc3740ec47b3 100644 (file)
@@ -19,10 +19,11 @@ BINCONFIG = "${bindir}/pcap-config"
 
 # Explicitly disable dag support. We don't have recipe for it and if enabled here,
 # configure script poisons the include dirs with /usr/local/include even when the
-# support hasn't been detected.
+# support hasn't been detected. Do the same thing for DPDK.
 EXTRA_OECONF = " \
                  --with-pcap=linux \
                  --without-dag \
+                 --without-dpdk \
                  "
 EXTRA_AUTORECONF += "--exclude=aclocal"