]> code.ossystems Code Review - openembedded-core.git/commitdiff
bzip2: set the autoconf package version to the recipe version
authorAndreas Obergschwandtner <andreas.obergschwandtner@skidata.com>
Mon, 5 Aug 2019 14:35:55 +0000 (16:35 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Aug 2019 15:08:08 +0000 (16:08 +0100)
This is done to require only a single version change if bzip2
is updated and fixes also setting package version 1.0.6 for
bzip2 1.0.8.

Signed-off-by: Andreas Obergschwandtner <andreas.obergschwandtner@skidata.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/bzip2/bzip2/configure.ac
meta/recipes-extended/bzip2/bzip2_1.0.8.bb

index e2bf1bf1108b6c167590dc3d60932d5c8e77f183..b8abade2d960fc920bc292b2d4f862a3c74b7c0e 100644 (file)
@@ -1,6 +1,6 @@
 AC_PREREQ([2.57])
 
-AC_INIT(bzip2, 1.0.6)
+AC_INIT(bzip2, %BZIP2_VERSION%)
 AM_INIT_AUTOMAKE(foreign)
 AM_MAINTAINER_MODE
 
index 6f86b451ae04c47a8b836e7091532c167507b7da..8e9b779e672e301fec7c511b1d163b0bc0128c23 100644 (file)
@@ -29,6 +29,10 @@ ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2"
 #install binaries to bzip2-native under sysroot for replacement-native
 EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
 
+do_configure_prepend () {
+    sed -i -e "s|%BZIP2_VERSION%|${PV}|" ${S}/configure.ac
+}
+
 do_install_ptest () {
        sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
 }