]> code.ossystems Code Review - openembedded-core.git/commitdiff
intltool: Upgrade 0.50.2 -> 0.51.0
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Wed, 8 Jul 2015 20:01:23 +0000 (21:01 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jul 2015 21:53:21 +0000 (22:53 +0100)
* Remove uclibc.patch as the whole localedir guessing code has been
  removed upstream.

* Add patch to fix deprecation warnings (and the resulting broken install paths)
  when using Perl 5.22 (RB)

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/intltool/intltool-0.50.2/uclibc.patch [deleted file]
meta/recipes-devtools/intltool/intltool/intltool-nowarn.patch [moved from meta/recipes-devtools/intltool/intltool-0.50.2/intltool-nowarn.patch with 100% similarity]
meta/recipes-devtools/intltool/intltool/noperlcheck.patch [moved from meta/recipes-devtools/intltool/intltool-0.50.2/noperlcheck.patch with 100% similarity]
meta/recipes-devtools/intltool/intltool/perl-522-deprecations.patch [new file with mode: 0644]
meta/recipes-devtools/intltool/intltool/remove-xml-check.patch [moved from meta/recipes-devtools/intltool/intltool-0.50.2/remove-xml-check.patch with 100% similarity]
meta/recipes-devtools/intltool/intltool/use-nativeperl.patch [moved from meta/recipes-devtools/intltool/intltool-0.50.2/use-nativeperl.patch with 100% similarity]
meta/recipes-devtools/intltool/intltool_0.51.0.bb [moved from meta/recipes-devtools/intltool/intltool_0.50.2.bb with 74% similarity]

diff --git a/meta/recipes-devtools/intltool/intltool-0.50.2/uclibc.patch b/meta/recipes-devtools/intltool/intltool-0.50.2/uclibc.patch
deleted file mode 100644 (file)
index 145c181..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-on uclibc systems localedir should point to /usr/'share' as usual.
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: intltool-0.50.2/intltool.m4
-===================================================================
---- intltool-0.50.2.orig/intltool.m4   2014-03-15 22:09:01.016627665 -0700
-+++ intltool-0.50.2/intltool.m4        2014-03-15 22:12:09.732631206 -0700
-@@ -173,6 +173,9 @@
-     AC_CHECK_FUNC(bind_textdomain_codeset,
-       [DATADIRNAME=share], [DATADIRNAME=lib])
-     ;;
-+    *-*-*uclibc*)
-+    [DATADIRNAME=share]
-+    ;;
-     *)
-     [DATADIRNAME=lib]
-     ;;
diff --git a/meta/recipes-devtools/intltool/intltool/perl-522-deprecations.patch b/meta/recipes-devtools/intltool/intltool/perl-522-deprecations.patch
new file mode 100644 (file)
index 0000000..eb52172
--- /dev/null
@@ -0,0 +1,55 @@
+Perl 5.22 has deprecated some regex features, which causes warnings when
+intltool-update runs:
+
+Unescaped left brace in regex is deprecated, passed through in regex; marked by
+<-- HERE in m/^(.*)\${ <-- HERE ?([A-Z_]+)}?(.*)$/ at
+/data/poky-master/tmp/sysroots/x86_64-linux/usr/bin/intltool-update line 1065.
+
+Take a patch from Debian to solve this.
+
+Upstream-Status: Submitted (https://bugs.launchpad.net/intltool/+bug/1465010)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+--- intltool-0.51.0-ORIG/intltool-update.in    2015-05-27 00:20:43.038379963 +0200
++++ intltool-0.51.0/intltool-update.in 2015-05-27 00:23:53.309078052 +0200
+@@ -1062,7 +1062,7 @@
+       }
+     }
+-    if ($str =~ /^(.*)\${?([A-Z_]+)}?(.*)$/)
++    if ($str =~ /^(.*)\$\{?([A-Z_]+)\}?(.*)$/)
+     {
+       my $rest = $3;
+       my $untouched = $1;
+@@ -1190,10 +1190,10 @@
+       $name    =~ s/\(+$//g;
+       $version =~ s/\(+$//g;
+-      $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\${?AC_PACKAGE_NAME}?/);
+-      $varhash{"PACKAGE"} = $name if (not $name =~ /\${?PACKAGE}?/);
+-      $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\${?AC_PACKAGE_VERSION}?/);
+-      $varhash{"VERSION"} = $version if (not $name =~ /\${?VERSION}?/);
++      $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\$\{?AC_PACKAGE_NAME\}?/);
++      $varhash{"PACKAGE"} = $name if (not $name =~ /\$\{?PACKAGE\}?/);
++      $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\$\{?AC_PACKAGE_VERSION\}?/);
++      $varhash{"VERSION"} = $version if (not $name =~ /\$\{?VERSION\}?/);
+     }
+     if ($conf_source =~ /^AC_INIT\(([^,\)]+),([^,\)]+)[,]?([^,\)]+)?/m)
+@@ -1219,11 +1219,11 @@
+       $version =~ s/\(+$//g;
+         $bugurl  =~ s/\(+$//g if (defined $bugurl);
+-      $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\${?AC_PACKAGE_NAME}?/);
+-      $varhash{"PACKAGE"} = $name if (not $name =~ /\${?PACKAGE}?/);
+-      $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\${?AC_PACKAGE_VERSION}?/);
+-      $varhash{"VERSION"} = $version if (not $name =~ /\${?VERSION}?/);
+-        $varhash{"PACKAGE_BUGREPORT"} = $bugurl if (defined $bugurl and not $bugurl =~ /\${?\w+}?/);
++      $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\$\{?AC_PACKAGE_NAME\}?/);
++      $varhash{"PACKAGE"} = $name if (not $name =~ /\$\{?PACKAGE\}?/);
++      $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\$\{?AC_PACKAGE_VERSION\}?/);
++      $varhash{"VERSION"} = $version if (not $name =~ /\$\{?VERSION\}?/);
++        $varhash{"PACKAGE_BUGREPORT"} = $bugurl if (defined $bugurl and not $bugurl =~ /\$\{?\w+\}?/);
+     }
+     # \s makes this not work, why?
\ No newline at end of file
similarity index 74%
rename from meta/recipes-devtools/intltool/intltool_0.50.2.bb
rename to meta/recipes-devtools/intltool/intltool_0.51.0.bb
index 483239d4722e23f01464a3c2e062c135a0a6d770..d520d43c1d42ba37621bd2228ff4dc5449b1bdd1 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
 SRC_URI += "file://intltool-nowarn.patch \
-           file://uclibc.patch \
+            file://perl-522-deprecations.patch \
            ${NATIVEPATCHES} \
            "
 
@@ -15,5 +15,5 @@ NATIVEPATCHES = "file://noperlcheck.patch \
                  file://remove-xml-check.patch"
 NATIVEPATCHES_class-native = "file://use-nativeperl.patch" 
 
-SRC_URI[md5sum] = "23fbd879118253cb99aeac067da5f591"
-SRC_URI[sha256sum] = "67f25c5c6fb71d095793a7f895b245e65e829e8bde68c6c8b4c912144ff34406"
+SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63"
+SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd"