]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: Skip assembler optimized code for powerpc64 with musl
authorSerhey Popovych <serhe.popovych@gmail.com>
Fri, 14 Dec 2018 17:54:37 +0000 (19:54 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 15 Dec 2018 17:10:44 +0000 (17:10 +0000)
This code is written for elfv1 ABI in mind and linked as such: disable
all optimizations at the moment when building for powerpc64 with musl.

Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb
meta/recipes-connectivity/openssl/openssl_1.1.1a.bb

index 6518dac076315234327465e16d91d9359f806a82..9d67053b7ade2c9c73b6f678e9d6529b5bcda64f 100644 (file)
@@ -81,6 +81,7 @@ CCACHE = ""
 
 TERMIO ?= "-DTERMIO"
 TERMIO_libc-musl = "-DTERMIOS"
+EXTRA_OECONF_append_libc-musl_powerpc64 = " no-asm"
 
 CFLAG = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
          ${TERMIO} ${CFLAGS} -Wall"
index 042e023de5c8087dcbe1194ef45aea3c58f48ff9..5c4e69cfb77d94e9f857faa4a6a7ed28f503f1d5 100644 (file)
@@ -35,6 +35,7 @@ do_configure[cleandirs] = "${B}"
 #| ./libcrypto.so: undefined reference to `setcontext'
 #| ./libcrypto.so: undefined reference to `makecontext'
 EXTRA_OECONF_append_libc-musl = " no-async"
+EXTRA_OECONF_append_libc-musl_powerpc64 = " no-asm"
 
 # This prevents openssl from using getrandom() which is not available on older glibc versions
 # (native versions can be built with newer glibc, but then relocated onto a system with older glibc)