]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston: Add missing DEPENDS on wayland-native
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 24 Jan 2016 10:49:14 +0000 (10:49 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 24 Jan 2016 10:55:35 +0000 (10:55 +0000)
Weston needs wayland-scanner which comes from wayland-native. Add the missing
dependency to avoid build failures from:

bitbake wayland; bitbake wayland-native:do_clean weston:do_cleansstate; bitbake weston

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/wayland/weston_1.9.0.bb

index e14ea9d7010d60449d0739f183082e702a46326a..16a788d2a39d309e23a3987730f47484521107bb 100644 (file)
@@ -22,7 +22,7 @@ inherit autotools pkgconfig useradd distro_features_check
 REQUIRED_DISTRO_FEATURES = "opengl"
 
 DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
-DEPENDS += "wayland libinput virtual/egl pango"
+DEPENDS += "wayland libinput virtual/egl pango wayland-native"
 
 EXTRA_OECONF = "--enable-setuid-install \
                 --enable-simple-clients \