]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: enable 64 bit file support
authorSaul Wold <sgw@linux.intel.com>
Fri, 6 Jun 2014 00:09:04 +0000 (17:09 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jun 2014 08:32:23 +0000 (09:32 +0100)
When running 32bit code on a large filessytem with 64bit inodes, the
fontcache was not being created correctly because an EOVERFLOW was being
returned from the fstat when reading the 64 inode on a 32bit system.

The fontcache is created at rootfs time on the host system via qemu.

[YOCTO #6338]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/freetype/freetype_2.5.2.bb

index fd8a9e184e361814b8269af02a4d75d3d36fbced..7119990d145949857f19ef050b83ade7093f5ecc 100644 (file)
@@ -27,6 +27,8 @@ LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
 EXTRA_OEMAKE_class-native = ""
 EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
+
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"