]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Fix nativesdk install path
authorChristian Glindkamp <christian.glindkamp@taskit.de>
Thu, 27 Sep 2012 12:20:57 +0000 (14:20 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 27 Sep 2012 15:21:47 +0000 (16:21 +0100)
Commit 38234f2e276356b1d77a87ceabc486107e336d19 tried to fix the sed
expressions by anchoring the left side of the search regexp to prevent
$prefix$prefix type expression in the perl config. For nativesdk this is
not enough. Adding anchors on both side fixes this.

Signed-off-by: Christian Glindkamp <christian.glindkamp@taskit.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl_5.14.2.bb

index 3c1360f9a38a41ed56637c30e1c60fce5849e9b8..00098553ddf7ac7c117437e4326970c56ba90835 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db grep-native"
 DEPENDS += "gdbm zlib"
-PR = "r9"
+PR = "r10"
 
 # 5.10.1 has Module::Build built-in
 PROVIDES += "libmodule-build-perl"
@@ -150,9 +150,9 @@ do_configure() {
                -e 's,@ARCH@-thread-multi,,g' \
                -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
                -e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \
-               -e "s%\([ \"^\',=]\+\)/usr/include%\1${STAGING_INCDIR}%g" \
-              -e "s%\([ \"^\',=]\+\)/usr/lib/%\1${libdir}/%g" \
-              -e "s%\([ \"^\',=]\+\)/usr/%\1${exec_prefix}/%g" \
+               -e "s%\([ \"^\',=]\+\)/usr/include\([ \"^\',=]\+\)%\1${STAGING_INCDIR}\2%g" \
+              -e "s%\([ \"^\',=]\+\)/usr/lib/\([ \"^\',=]\+\)%\1${libdir}/\2%g" \
+              -e "s%\([ \"^\',=]\+\)/usr/\([ \"^\',=]\+\)%\1${exec_prefix}/\2%g" \
               -e "s%/perl5%/perl%g" \
             config.sh-${TARGET_ARCH}-${TARGET_OS}