]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils: fix the installed location of libiberty.a file
authorNitin A Kamble <nitin.a.kamble@intel.com>
Sat, 14 Aug 2010 00:08:19 +0000 (17:08 -0700)
committerSaul Wold <Saul.Wold@intel.com>
Sat, 14 Aug 2010 00:19:16 +0000 (17:19 -0700)
This fixes:
  [BUGID #209]

the libiberty was getting installed in usr/lib/lib64 path which was
leaving prelink-native recipe wondering where to get libiberty.
  Fix the path and prelink-native recipe is building fine now.

Patch added:
 libiberty_path_fix.patch

meta/packages/binutils/binutils-2.20.1/libiberty_path_fix.patch [new file with mode: 0644]
meta/packages/binutils/binutils_2.20.1.bb

diff --git a/meta/packages/binutils/binutils-2.20.1/libiberty_path_fix.patch b/meta/packages/binutils/binutils-2.20.1/libiberty_path_fix.patch
new file mode 100644 (file)
index 0000000..36a14d7
--- /dev/null
@@ -0,0 +1,20 @@
+don't let the distro compiler point to the wrong installation location
+
+Thanks to RP for helping find the source code causing the issue.
+
+2010/08/13
+Nitin A Kamble <nitin.a.kamble@intel.com>
+Index: binutils-2.20.1/libiberty/Makefile.in
+===================================================================
+--- binutils-2.20.1.orig/libiberty/Makefile.in
++++ binutils-2.20.1/libiberty/Makefile.in
+@@ -327,7 +327,8 @@ install: install_to_$(INSTALL_DEST) inst
+ # multilib-specific flags, it's overridden by FLAGS_TO_PASS from the
+ # default multilib, so we have to take CFLAGS into account as well,
+ # since it will be passed the multilib flags.
+-MULTIOSDIR = `$(CC) $(CFLAGS) -print-multi-os-directory`
++#MULTIOSDIR = `$(CC) $(CFLAGS) -print-multi-os-directory`
++MULTIOSDIR = ""
+ install_to_libdir: all
+       ${mkinstalldirs} $(DESTDIR)$(libdir)/$(MULTIOSDIR)
+       $(INSTALL_DATA) $(TARGETLIB) $(DESTDIR)$(libdir)/$(MULTIOSDIR)/$(TARGETLIB)n
index 88a3dec28061a72685644a79a92382a73fb7963a..d5cd985ccabcc529c7242392e23bf0fc9babe8c9 100644 (file)
@@ -1,6 +1,6 @@
 require binutils.inc
 
-PR = "r1"
+PR = "r2"
 
 LIC_FILES_CHKSUM="\
     file://src-release;endline=17;md5=4830a9ef968f3b18dd5e9f2c00db2d35\
@@ -26,6 +26,7 @@ SRC_URI = "\
      file://binutils-x86_64_i386_biarch.patch \
      file://binutils-mips-pie.patch \
      file://binutils-libtool.patch \
+     file://libiberty_path_fix.patch \
      "
 
 # powerpc patches