]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub: Initial commit
authorSamuel Ortiz <sameo@openedhand.com>
Wed, 8 Oct 2008 08:16:38 +0000 (08:16 +0000)
committerSamuel Ortiz <sameo@openedhand.com>
Wed, 8 Oct 2008 08:16:38 +0000 (08:16 +0000)
We need grub for building netbook installation images

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5442 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/grub/grub-0.97/autohell.patch [new file with mode: 0644]
meta/packages/grub/grub_0.97.bb [new file with mode: 0644]

diff --git a/meta/packages/grub/grub-0.97/autohell.patch b/meta/packages/grub/grub-0.97/autohell.patch
new file mode 100644 (file)
index 0000000..279c529
--- /dev/null
@@ -0,0 +1,19 @@
+---
+ configure.ac |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: grub-0.97/configure.ac
+===================================================================
+--- grub-0.97.orig/configure.ac        2008-09-12 17:39:52.000000000 +0200
++++ grub-0.97/configure.ac     2008-09-12 17:40:21.000000000 +0200
+@@ -60,8 +60,8 @@ AC_PROG_CC
+ _AM_DEPENDENCIES(CC)
+ dnl Because recent automake complains about AS, set it here.
+-CCAS="$CC"
+-AC_SUBST(CCAS)
++AM_PROG_AS
++AC_SUBST(AS)
+ AC_ARG_WITH(binutils,
+   [  --with-binutils=DIR     search the directory DIR to find binutils])
diff --git a/meta/packages/grub/grub_0.97.bb b/meta/packages/grub/grub_0.97.bb
new file mode 100644 (file)
index 0000000..e93e4de
--- /dev/null
@@ -0,0 +1,26 @@
+DESCRIPTION = "GRUB is the GRand Unified Bootloader"
+HOMEPAGE = "http://www.gnu.org/software/grub"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+RDEPENDS = "diffutils"
+PR = "r2"
+
+SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz; \
+          file://autohell.patch;patch=1 "
+
+inherit autotools
+
+python __anonymous () {
+    import re
+    host = bb.data.getVar('HOST_SYS', d, 1)
+    if not re.match('i.86.*-linux', host):
+        raise bb.parse.SkipPackage("incompatible with host %s" % host)
+}
+
+do_install_append_vmware() {
+       mkdir -p ${D}/boot/
+       ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub
+}
+
+FILES_${PN}-doc = "${datadir}"
+FILES_${PN} = "/boot /usr"