]> code.ossystems Code Review - openembedded-core.git/commitdiff
ipkg: dropped
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 17 Mar 2008 13:19:22 +0000 (13:19 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 17 Mar 2008 13:19:22 +0000 (13:19 +0000)
Signed-off-by: Marcin Juszkiewicz <hrw@openedhand.com>
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4030 311d38ba-8fff-0310-9ca6-ca027cbcb966

13 files changed:
meta/packages/ipkg/files/enable_debversion.patch [deleted file]
meta/packages/ipkg/files/fix_tar_extension.patch [deleted file]
meta/packages/ipkg/files/ipkg_bugfix.patch [deleted file]
meta/packages/ipkg/files/noupdalt.patch [deleted file]
meta/packages/ipkg/files/terse.patch [deleted file]
meta/packages/ipkg/files/uclibc.patch [deleted file]
meta/packages/ipkg/files/uninclude-replace.patch [deleted file]
meta/packages/ipkg/files/update_version_comparision.patch [deleted file]
meta/packages/ipkg/ipkg-native.inc [deleted file]
meta/packages/ipkg/ipkg-native_0.99.154.bb [deleted file]
meta/packages/ipkg/ipkg-sdk_0.99.154.bb [deleted file]
meta/packages/ipkg/ipkg.inc [deleted file]
meta/packages/ipkg/ipkg_0.99.154.bb [deleted file]

diff --git a/meta/packages/ipkg/files/enable_debversion.patch b/meta/packages/ipkg/files/enable_debversion.patch
deleted file mode 100644 (file)
index e9c3a7a..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-OE makes heavy use of the revision field so it makes sense to 
-enable it. We don't want the familiar stuff though so patch that 
-out.
-
-RP - 19/02/2008
-
-Index: ipkg-0.99.163/pkg.c
-===================================================================
---- ipkg-0.99.163.orig/pkg.c   2008-02-19 00:35:03.000000000 +0000
-+++ ipkg-0.99.163/pkg.c        2008-02-19 00:36:02.000000000 +0000
-@@ -1118,15 +1118,11 @@
-         return r;
-      }
--#ifdef USE_DEBVERSION
-      r = verrevcmp(pkg->revision, ref_pkg->revision);
-      if (r) {
-         return r;
-      }
--     r = verrevcmp(pkg->familiar_revision, ref_pkg->familiar_revision);
--#endif
--
-      return r;
- }
-@@ -1240,10 +1236,7 @@
- {
-      char *complete_version;
-      char *epoch_str;
--#ifdef USE_DEBVERSION
-      char *revision_str;
--     char *familiar_revision_str;
--#endif
-      if (pkg->epoch) {
-         sprintf_alloc(&epoch_str, "%d:", pkg->epoch);
-@@ -1251,33 +1244,18 @@
-         epoch_str = strdup("");
-      }
--#ifdef USE_DEBVERSION
-      if (pkg->revision && strlen(pkg->revision)) {
-         sprintf_alloc(&revision_str, "-%s", pkg->revision);
-      } else {
-         revision_str = strdup("");
-      }
--     if (pkg->familiar_revision && strlen(pkg->familiar_revision)) {
--        sprintf_alloc(&familiar_revision_str, "-fam%s", pkg->familiar_revision);
--     } else {
--        familiar_revision_str = strdup("");
--     }
--#endif
--#ifdef USE_DEBVERSION
--     sprintf_alloc(&complete_version, "%s%s%s%s",
--                 epoch_str, pkg->version, revision_str, familiar_revision_str);
--#else
--     sprintf_alloc(&complete_version, "%s%s",
--                 epoch_str, pkg->version);
--#endif
-+     sprintf_alloc(&complete_version, "%s%s%s",
-+                 epoch_str, pkg->version, revision_str);
-      free(epoch_str);
--#ifdef USE_DEBVERSION
-      free(revision_str);
--     free(familiar_revision_str);
--#endif
-      return complete_version;
- }
-Index: ipkg-0.99.163/pkg_parse.c
-===================================================================
---- ipkg-0.99.163.orig/pkg_parse.c     2008-02-19 00:35:03.000000000 +0000
-+++ ipkg-0.99.163/pkg_parse.c  2008-02-19 00:38:42.000000000 +0000
-@@ -105,9 +105,7 @@
- int parseVersion(pkg_t *pkg, char *raw)
- {
-   char *colon, *eepochcolon;
--#ifdef USE_DEBVERSION
-   char *hyphen;
--#endif
-   unsigned long epoch;
-   if (!*raw) {
-@@ -149,23 +147,12 @@
-   }
-   strcpy(pkg->version, raw);
--#ifdef USE_DEBVERSION
-   hyphen= strrchr(pkg->version,'-');
-   if (hyphen) {
-     *hyphen++= 0;
--    if (strncmp("fam", hyphen, 3) == 0) {
--      pkg->familiar_revision=hyphen+3;
--      hyphen= strrchr(pkg->version,'-');
--      if (hyphen) {
--      *hyphen++= 0;
--      pkg->revision = hyphen;
--      }
--    } else {
-       pkg->revision = hyphen;
--    }
-   }
--#endif
- /*
-   fprintf(stderr,"Parsed version: %lu, %s, %s, %s\n",
diff --git a/meta/packages/ipkg/files/fix_tar_extension.patch b/meta/packages/ipkg/files/fix_tar_extension.patch
deleted file mode 100644 (file)
index d9db5fc..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-Index: C/libbb/unarchive.c
-===================================================================
---- C.orig/libbb/unarchive.c   2005-02-05 16:58:19.000000000 -0500
-+++ C/libbb/unarchive.c        2006-08-08 08:10:14.268431408 -0400
-@@ -28,7 +28,7 @@
- #include "libbb.h"
- #define CONFIG_FEATURE_TAR_OLDGNU_COMPATABILITY 1
--// #define CONFIG_FEATURE_TAR_GNU_EXTENSIONS
-+#define CONFIG_FEATURE_TAR_GNU_EXTENSIONS 1
- #ifdef CONFIG_FEATURE_TAR_GNU_EXTENSIONS
- static char *longname = NULL;
-@@ -657,7 +657,10 @@
- # ifdef CONFIG_FEATURE_TAR_GNU_EXTENSIONS
-       case 'L': {
-                       longname = xmalloc(tar_entry->size + 1);
--                      archive_xread_all((int) tar_stream, longname, tar_entry->size);
-+                      if(fread(longname, tar_entry->size, 1, tar_stream) != 1) {
-+                              error_msg("Short read in gnu extension");
-+                              return(NULL);
-+                      } 
-                       longname[tar_entry->size] = '\0';
-                       archive_offset += tar_entry->size;
-@@ -665,7 +668,10 @@
-               }
-       case 'K': {
-                       linkname = xmalloc(tar_entry->size + 1);
--                      archive_xread_all((int) tar_stream, longname, tar_entry->size);
-+                      if(fread(linkname, tar_entry->size, 1, tar_stream) != 1) {
-+                              error_msg("Short read in gnu extension");
-+                              return(NULL);
-+                      } 
-                       linkname[tar_entry->size] = '\0';
-                       archive_offset += tar_entry->size;
diff --git a/meta/packages/ipkg/files/ipkg_bugfix.patch b/meta/packages/ipkg/files/ipkg_bugfix.patch
deleted file mode 100644 (file)
index 51eccbb..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-Index: C/ipkg_conf.c
-===================================================================
---- C.orig/ipkg_conf.c 2005-06-21 13:59:32.000000000 +0000
-+++ C/ipkg_conf.c      2007-11-27 01:11:17.000000000 +0000
-@@ -423,6 +423,7 @@
-      nv_pair_t *nv_pair;
-      pkg_dest_t *dest;
-      char *root_dir;
-+     char *list_dir2;
-      for (iter = nv_pair_list->head; iter; iter = iter->next) {
-         nv_pair = iter->data;
-@@ -432,8 +433,14 @@
-         } else {
-              root_dir = strdup(nv_pair->value);
-         }
--        dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, lists_dir);
-+        if (conf->offline_root) {
-+             sprintf_alloc(&list_dir2, "%s%s", conf->offline_root, lists_dir);
-+        } else {
-+             list_dir2 = strdup(lists_dir);
-+        }
-+        dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, list_dir2);
-         free(root_dir);
-+        free(list_dir2);
-         if (dest == NULL) {
-              continue;
-         }
-@@ -562,13 +569,13 @@
-         } else if (strcmp(type, "dest") == 0) {
-              nv_pair_list_append(tmp_dest_nv_pair_list, name, value);
-         } else if (strcmp(type, "lists_dir") == 0) {
--             *lists_dir = realloc(*lists_dir,strlen(value)+1);
-+             *lists_dir = realloc(*lists_dir,strlen(name)+1);
-                if (*lists_dir == NULL) {
-                   ipkg_message(conf, IPKG_ERROR, "ERROR: Not enough memory\n");
-                   free(options);
-                   return EINVAL;
-                }
--               sprintf (*lists_dir,"%s",value);
-+               sprintf (*lists_dir,"%s", name);
-         } else if (strcmp(type, "arch") == 0) {
-              ipkg_message(conf, IPKG_INFO, "supported arch %s priority (%s)\n", name, value);
-              if (!value) {
diff --git a/meta/packages/ipkg/files/noupdalt.patch b/meta/packages/ipkg/files/noupdalt.patch
deleted file mode 100644 (file)
index f668e82..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
----
- Makefile.am |    2 --
- 1 file changed, 2 deletions(-)
-
---- C.orig/Makefile.am
-+++ C/Makefile.am
-@@ -10,8 +10,6 @@ bin_PROGRAMS = ipkg-cl
- lib_LTLIBRARIES = libipkg.la
--bin_SCRIPTS = update-alternatives
--
- # ipkg_LDADD = libbb/libbb.a replace/libreplace.a
- #ipkg_cl_LDADD = libipkg.la libbb/libbb.la replace/libreplace.a 
diff --git a/meta/packages/ipkg/files/terse.patch b/meta/packages/ipkg/files/terse.patch
deleted file mode 100644 (file)
index 3c4d6be..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
-       int result;
-       p_userdata = userdata;
-       result = (cmd->fun)(conf, argc, argv);
--        if ( result == 0 ) {
--           ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
--        } else {
-+        if ( result != 0 ) {
-            ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
-         }
-    
diff --git a/meta/packages/ipkg/files/uclibc.patch b/meta/packages/ipkg/files/uclibc.patch
deleted file mode 100644 (file)
index d0d3a3f..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: C/libbb/libbb.h
-===================================================================
---- C.orig/libbb/libbb.h       2003-02-24 10:31:52.000000000 -0500
-+++ C/libbb/libbb.h    2005-01-20 03:07:10.031420944 -0500
-@@ -340,7 +340,7 @@
- #define CONSOLE_DEV "/dev/console"
- /* Cope with mmu-less systems somewhat gracefully */
--#if defined(__UCLIBC__) && !defined(__UCLIBC_HAS_MMU__)
-+#if defined(__UCLIBC__) && !defined(__ARCH_HAS_MMU__)
- #define fork  vfork
- #endif
diff --git a/meta/packages/ipkg/files/uninclude-replace.patch b/meta/packages/ipkg/files/uninclude-replace.patch
deleted file mode 100644 (file)
index a3ed220..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- C/includes.h       2003-03-28 19:36:22.000000000 +0000
-+++ C/includes.h       2004-07-28 03:41:11.000000000 +0100
-@@ -48,6 +48,6 @@
- # include <unistd.h>
- #endif
--#include "replace/replace.h"
-+//#include "replace/replace.h"
- #endif
diff --git a/meta/packages/ipkg/files/update_version_comparision.patch b/meta/packages/ipkg/files/update_version_comparision.patch
deleted file mode 100644 (file)
index b0d0df5..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-Update the version comparision to a more recent one from dpkg. This
-means it now recognises 0.0-foo > 0.0+foo as it should.
-
-RP - 19/02/2008
-
-Index: ipkg-0.99.163/pkg.c
-===================================================================
---- ipkg-0.99.163.orig/pkg.c   2008-02-18 11:24:45.000000000 +0000
-+++ ipkg-0.99.163/pkg.c        2008-02-19 00:24:50.000000000 +0000
-@@ -1128,43 +1130,37 @@
-      return r;
- }
--int verrevcmp(const char *val, const char *ref)
--{
--     int vc, rc;
--     long vl, rl;
--     const char *vp, *rp;
--     const char *vsep, *rsep;
--    
--     if (!val) val= "";
--     if (!ref) ref= "";
--     for (;;) {
--        vp= val;  while (*vp && !isdigit(*vp)) vp++;
--        rp= ref;  while (*rp && !isdigit(*rp)) rp++;
--        for (;;) {
--             vc= (val == vp) ? 0 : *val++;
--             rc= (ref == rp) ? 0 : *ref++;
--             if (!rc && !vc) break;
--             if (vc && !isalpha(vc)) vc += 256; /* assumes ASCII character set */
--             if (rc && !isalpha(rc)) rc += 256;
--             if (vc != rc) return vc - rc;
--        }
--        val= vp;
--        ref= rp;
--        vl=0;  if (isdigit(*vp)) vl= strtol(val,(char**)&val,10);
--        rl=0;  if (isdigit(*rp)) rl= strtol(ref,(char**)&ref,10);
--        if (vl != rl) return vl - rl;
--
--        vc = *val;
--        rc = *ref;
--        vsep = strchr(".-", vc);
--        rsep = strchr(".-", rc);
--        if (vsep && !rsep) return -1;
--        if (!vsep && rsep) return +1;
--
--        if (!*val && !*ref) return 0;
--        if (!*val) return -1;
--        if (!*ref) return +1;
--     }
-+/* assume ascii; warning: evaluates x multiple times! */
-+#define order(x) ((x) == '~' ? -1 \
-+              : isdigit((x)) ? 0 \
-+              : !(x) ? 0 \
-+              : isalpha((x)) ? (x) \
-+              : (x) + 256)
-+
-+static int verrevcmp(const char *val, const char *ref) {
-+  if (!val) val= "";
-+  if (!ref) ref= "";
-+
-+  while (*val || *ref) {
-+    int first_diff= 0;
-+
-+    while ( (*val && !isdigit(*val)) || (*ref && !isdigit(*ref)) ) {
-+      int vc= order(*val), rc= order(*ref);
-+      if (vc != rc) return vc - rc;
-+      val++; ref++;
-+    }
-+
-+    while ( *val == '0' ) val++;
-+    while ( *ref == '0' ) ref++;
-+    while (isdigit(*val) && isdigit(*ref)) {
-+      if (!first_diff) first_diff= *val - *ref;
-+      val++; ref++;
-+    }
-+    if (isdigit(*val)) return 1;
-+    if (isdigit(*ref)) return -1;
-+    if (first_diff) return first_diff;
-+  }
-+  return 0;
- }
- int pkg_version_satisfied(pkg_t *it, pkg_t *ref, const char *op)
diff --git a/meta/packages/ipkg/ipkg-native.inc b/meta/packages/ipkg/ipkg-native.inc
deleted file mode 100644 (file)
index 89b1a5f..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-# NOTE: ipkg now obeys ${libdir}, so ipkg-native now installs
-# things into the wrong location inside of offline_root.  Backup
-# the target libdir and use that.
-target_libdir := "${libdir}"
-
-inherit native
-
-EXTRA_OECONF += "--with-ipkgdir=${target_libdir}/ipkg"
-
-DEPENDS = "libtool-native automake-native virtual/update-alternatives-native"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ipkg-${PV}"
-PROVIDES = ""
diff --git a/meta/packages/ipkg/ipkg-native_0.99.154.bb b/meta/packages/ipkg/ipkg-native_0.99.154.bb
deleted file mode 100644 (file)
index 8435b4d..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-require ipkg.inc
-require ipkg-native.inc
-
-PR = "r3"
diff --git a/meta/packages/ipkg/ipkg-sdk_0.99.154.bb b/meta/packages/ipkg/ipkg-sdk_0.99.154.bb
deleted file mode 100644 (file)
index b49fc93..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require ipkg.inc
-inherit sdk
diff --git a/meta/packages/ipkg/ipkg.inc b/meta/packages/ipkg/ipkg.inc
deleted file mode 100644 (file)
index e1c5440..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-DESCRIPTION = "Itsy Package Manager"
-DESCRIPTION_libipkg = "Itsy Package Manager Library"
-SECTION = "base"
-LICENSE = "GPL"
-PROVIDES = "virtual/ipkg libipkg"
-
-FILES_libipkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so ${includedir}"
-FILES_libipkg = "${libdir}/*.so.*"
-AUTO_LIBNAME_PKGS = "libipkg"
-
-SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \
-        file://fix_tar_extension.patch;patch=1 \
-        file://update_version_comparision.patch;patch=1 \
-        file://enable_debversion.patch;patch=1 \
-        file://terse.patch;patch=1 \
-       file://ipkg_bugfix.patch;patch=1 \
-        file://noupdalt.patch;patch=1"
-
-S = "${WORKDIR}/ipkg/C"
-
-inherit autotools pkgconfig
-
-# Define a variable to allow distros to run configure earlier.
-# (for example, to enable loading of ethernet kernel modules before networking starts)
-IPKG_INIT_POSITION = "98"
-IPKG_INIT_POSITION_slugos = "41"
-
-pkg_postinst_ipkg () {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
-       install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
-       # this happens at S98 where our good 'ole packages script used to run
-       echo "#!/bin/sh
-ipkg-cl configure
-" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure
-       chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure
-fi
-
-update-alternatives --install ${bindir}/ipkg ipkg ${bindir}/ipkg-cl 100
-}
-
-pkg_postrm_ipkg () {
-#!/bin/sh
-update-alternatives --remove ipkg ${bindir}/ipkg-cl
-}
-
-do_stage() {
-       oe_libinstall -so libipkg ${STAGING_LIBDIR}
-       install -d ${STAGING_INCDIR}/replace/
-       install -m 0644 replace/replace.h ${STAGING_INCDIR}/replace/
-       install -d ${STAGING_INCDIR}/libipkg/
-       for f in *.h
-       do
-               install -m 0644 $f ${STAGING_INCDIR}/libipkg/
-       done
-}
-
-#
-# FIXME: Install /etc/ipkg.conf and /etc/ipkg/arch.conf
-#
diff --git a/meta/packages/ipkg/ipkg_0.99.154.bb b/meta/packages/ipkg/ipkg_0.99.154.bb
deleted file mode 100644 (file)
index 83773a5..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-require ipkg.inc
-PR = "r10"
-
-PACKAGES =+ "libipkg-dev libipkg"
-
-RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_update-alternatives}"