]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-yocto/meta: common-pc: add pci-siov to feature fragments
authorBruce Ashfield <bruce.ashfield@windriver.com>
Wed, 1 Feb 2017 15:30:33 +0000 (10:30 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 5 Feb 2017 09:20:21 +0000 (09:20 +0000)
The common-pc ethernet selection has drivers that depend on pci_iov
being defined. As such, we should include that feature fragment
or we get build warnings:

    ---------- CONFIG_BNX2X_SRIOV -----------------
    Config: CONFIG_BNX2X_SRIOV
    From:   work-shared/qemux86-64/kernel-source/.kernel-meta/configs/standard/bsp/common-pc/common-pc-eth.cfg
    Requested value:  CONFIG_BNX2X_SRIOV=y
    Actual value:

    Config 'BNX2X_SRIOV' has the following conditionals:
    BNX2X && PCI_IOV (value: "n")
    BNX2X && PCI_IOV (value: "n")
    Dependency values are:
      BNX2X [m] PCI_IOV [n] y [y]

    ---------- CONFIG_BNXT_SRIOV -----------------
    Config: CONFIG_BNXT_SRIOV
    From: work-shared/qemux86-64/kernel-source/.kernel-meta/configs/standard/bsp/common-pc/common-pc-eth.cfg
    Requested value:  CONFIG_BNXT_SRIOV=y
    Actual value:

    Config 'BNXT_SRIOV' has the following conditionals:
    BNXT && PCI_IOV (value: "n")
    BNXT && PCI_IOV (value: "n")
    Dependency values are:
      y [y] BNXT [m] PCI_IOV [n]

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
meta/recipes-kernel/linux/linux-yocto_4.9.bb

index e85d7c7b18c023e7792ae2811348ead0adcee9b6..155815e5df09fe5c0c21021b6ee7702d5f824e42 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "1d5e0d6f25c65f2404c47de11bef86f3dbc7f29d"
-SRCREV_meta ?= "0f58ab994909b0a15939f505458cec35a9663e5d"
+SRCREV_meta ?= "20b8e96e097b796673bea982918868d47d51081b"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.9.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
index a052dad5d1fa9ca63fa6d492454157038b657734..beb2d4de30e423c3f5c79e7283a46e6b987d8fcf 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_meta ?= "0f58ab994909b0a15939f505458cec35a9663e5d"
+SRCREV_meta ?= "20b8e96e097b796673bea982918868d47d51081b"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index a61bb137b9997f5ee48ae9d27017790a48001cba..241eb94f6ab0460134fbe92d84b0fbc3239c9e19 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
 SRCREV_machine_qemux86-64 ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
 SRCREV_machine_qemumips64 ?= "06fff8284bbec52a36fb3d054354db2f593376ac"
 SRCREV_machine ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_meta ?= "0f58ab994909b0a15939f505458cec35a9663e5d"
+SRCREV_meta ?= "20b8e96e097b796673bea982918868d47d51081b"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.9.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"