]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: fix configure with automake 1.11.2
authorNitin A Kamble <nitin.a.kamble@intel.com>
Thu, 29 Dec 2011 21:16:52 +0000 (13:16 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 Jan 2012 12:10:48 +0000 (12:10 +0000)
automake version 1.11.2 has made use of dir variables more strict.
The pkglibexec var can not have SCRIPTS suffix. Using pkgdata
instead.

Fixes this error:
| Makefile.am:25: `pkglibexecdir' is not a legitimate directory for
`SCRIPTS'
| autoreconf: automake failed with exit status: 1
| ERROR: autoreconf execution failed.
NOTE: package
systemtap-1.6+git1+820f2d22fc47fad6e09ba886efb9b91e1247cb39-r0: task
do_configure: Failed

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-kernel/systemtap/systemtap/fix_for_automake_1.11.2.patch [new file with mode: 0644]
meta/recipes-kernel/systemtap/systemtap_git.bb

diff --git a/meta/recipes-kernel/systemtap/systemtap/fix_for_automake_1.11.2.patch b/meta/recipes-kernel/systemtap/systemtap/fix_for_automake_1.11.2.patch
new file mode 100644 (file)
index 0000000..99e72b2
--- /dev/null
@@ -0,0 +1,46 @@
+Upstream-Status: Pending
+
+automake version 1.11.2 has made use of dir variables more strict.
+The pkglibexec var can not have SCRIPTS suffix. Using pkgdata
+instead.
+
+Fixes this error:
+| Makefile.am:25: `pkglibexecdir' is not a legitimate directory for `SCRIPTS'
+| autoreconf: automake failed with exit status: 1
+| ERROR: autoreconf execution failed.
+NOTE: package systemtap-1.6+git1+820f2d22fc47fad6e09ba886efb9b91e1247cb39-r0: task do_configure: Failed
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2011/12/29
+
+Index: git/Makefile.am
+===================================================================
+--- git.orig/Makefile.am
++++ git/Makefile.am
+@@ -22,7 +22,7 @@ dtrace.1 stap-merge.1\
+ stappaths.7
+ bin_SCRIPTS = stap-report
+-pkglibexec_SCRIPTS = stap-env
++pkgdata_SCRIPTS = stap-env
+ oldinclude_HEADERS = includes/sys/sdt.h includes/sys/sdt-config.h
+ bin_PROGRAMS =
+@@ -41,7 +41,7 @@ if BUILD_SERVER
+ man_MANS += stap-server.8
+ pkglibexec_PROGRAMS += stap-serverd stap-gen-cert
+ bin_SCRIPTS += stap-server
+-pkglibexec_SCRIPTS += stap-start-server stap-stop-server
++pkgdata_SCRIPTS += stap-start-server stap-stop-server
+ endif
+ endif
+@@ -127,7 +127,7 @@ install-scripts: install-binSCRIPTS inst
+       for f in $(bin_SCRIPTS); do \
+          sed -i -e "s,\$${PKGLIBEXECDIR},$(pkglibexecdir)/," $(DESTDIR)$(bindir)/$$f; \
+       done
+-      for f in $(pkglibexec_SCRIPTS); do \
++      for f in $(pkgdata_SCRIPTS); do \
+          sed -i -e "/INSTALL-HOOK/d;s,sysconfdir=.*,sysconfdir=$(sysconfdir),;s,pkglibexecdir=.*,pkglibexecdir=$(pkglibexecdir)/,;s,localstatedir=.*,localstatedir=$(localstatedir),;s,\$${PKGLIBEXECDIR},$(pkglibexecdir)/," $(DESTDIR)$(pkglibexecdir)/$$f; \
+       done
+ endif
index 732d9a7685e5c42af305554703664ce0c6309e7b..1c64be64ebc8cfa7ae837b7271a3cdcabaac5a87 100644 (file)
@@ -5,10 +5,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 DEPENDS = "elfutils sqlite3"
 
 SRCREV = "820f2d22fc47fad6e09ba886efb9b91e1247cb39"
-PR = "r0"
+PR = "r1"
 PV = "1.6+git${SRCPV}"
 
 SRC_URI = "git://sources.redhat.com/git/systemtap.git;protocol=git \
+           file://fix_for_automake_1.11.2.patch \
           "
 
 EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \