]> code.ossystems Code Review - openembedded-core.git/commitdiff
connman: remove xuser creation, RDEPEND on xuser-account
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Wed, 3 Jul 2013 14:11:38 +0000 (17:11 +0300)
committerSaul Wold <sgw@linux.intel.com>
Tue, 9 Jul 2013 14:56:11 +0000 (07:56 -0700)
[YOCTO #4345]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/connman/connman.inc

index e6584ffa6e0e3379d310c833eac46035734718dd..6b5ea0b17b188709fa253dac0004c0a6b45701c6 100644 (file)
@@ -60,14 +60,7 @@ SYSTEMD_SERVICE_${PN} = "connman.service"
 SYSTEMD_SERVICE_${PN}-vpn = "connman-vpn.service"
 SYSTEMD_WIRED_SETUP = "ExecStartPre=-${libdir}/connman/wired-setup"
 
-# IMPORTANT: because xuser is shared with rootless X, please make sure the
-# USERADD_PARAM is in sync with the one in xserver-nodm-init.bb
-USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--create-home \
-                       --groups video,tty,audio \
-                       --user-group xuser"
-
-inherit autotools gtk-doc pkgconfig systemd update-rc.d useradd
+inherit autotools gtk-doc pkgconfig systemd update-rc.d
 
 do_configure_append () {
        sed -i "s#ExecStart=#${SYSTEMD_WIRED_SETUP}\nExecStart=#" ${S}/src/connman.service
@@ -118,6 +111,7 @@ RDEPENDS_${PN} = "\
        ${@base_contains('PACKAGECONFIG', 'bluetooth', 'bluez4', '', d)} \
        ${@base_contains('PACKAGECONFIG', 'wifi','wpa-supplicant', '', d)} \
        ${@base_contains('PACKAGECONFIG', '3g','ofono', '', d)} \
+       xuser-account \
        "
 
 PACKAGES_DYNAMIC += "^${PN}-plugin-.*"