]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc: Security fix for CVE-2016-4429
authorArmin Kuster <akuster@mvista.com>
Sat, 9 Jul 2016 17:07:17 +0000 (10:07 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2016 07:32:11 +0000 (08:32 +0100)
Master will a have fix after pending update

Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-core/glibc/glibc/CVE-2016-4429.patch [new file with mode: 0644]
meta/recipes-core/glibc/glibc_2.23.bb

diff --git a/meta/recipes-core/glibc/glibc/CVE-2016-4429.patch b/meta/recipes-core/glibc/glibc/CVE-2016-4429.patch
new file mode 100644 (file)
index 0000000..56fcc0e
--- /dev/null
@@ -0,0 +1,89 @@
+From bc779a1a5b3035133024b21e2f339fe4219fb11c Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Mon, 23 May 2016 20:18:34 +0200
+Subject: [PATCH] CVE-2016-4429: sunrpc: Do not use alloca in clntudp_call [BZ
+ #20112]
+
+The call is technically in a loop, and under certain circumstances
+(which are quite difficult to reproduce in a test case), alloca
+can be invoked repeatedly during a single call to clntudp_call.
+As a result, the available stack space can be exhausted (even
+though individual alloca sizes are bounded implicitly by what
+can fit into a UDP packet, as a side effect of the earlier
+successful send operation).
+
+Upstream-Status: Backport
+CVE: CVE-2016-4429
+
+Signed-off-by: Armin Kuster <akuster@mvsita.com>
+
+---
+ ChangeLog         |  7 +++++++
+ NEWS              |  4 ++++
+ sunrpc/clnt_udp.c | 10 +++++++++-
+ 3 files changed, 20 insertions(+), 1 deletion(-)
+
+Index: git/NEWS
+===================================================================
+--- git.orig/NEWS
++++ git/NEWS
+@@ -110,6 +110,10 @@ Security related changes:
+   reporting the security impact of this issue, and Robert Holiday of
+   Ciena for reporting the related bug 18665. (CVE-2015-7547)
++* The Sun RPC UDP client could exhaust all available stack space when
++  flooded with crafted ICMP and UDP messages.  Reported by Aldy Hernandez'
++  alloca plugin for GCC.  (CVE-2016-4429)
++
+ The following bugs are resolved with this release:
+   [89] localedata: Locales nb_NO and nn_NO should transliterate æøå
+Index: git/sunrpc/clnt_udp.c
+===================================================================
+--- git.orig/sunrpc/clnt_udp.c
++++ git/sunrpc/clnt_udp.c
+@@ -388,9 +388,15 @@ send_again:
+         struct sock_extended_err *e;
+         struct sockaddr_in err_addr;
+         struct iovec iov;
+-        char *cbuf = (char *) alloca (outlen + 256);
++        char *cbuf = malloc (outlen + 256);
+         int ret;
++        if (cbuf == NULL)
++          {
++            cu->cu_error.re_errno = errno;
++            return (cu->cu_error.re_status = RPC_CANTRECV);
++          }
++
+         iov.iov_base = cbuf + 256;
+         iov.iov_len = outlen;
+         msg.msg_name = (void *) &err_addr;
+@@ -415,10 +421,12 @@ send_again:
+                cmsg = CMSG_NXTHDR (&msg, cmsg))
+             if (cmsg->cmsg_level == SOL_IP && cmsg->cmsg_type == IP_RECVERR)
+               {
++                free (cbuf);
+                 e = (struct sock_extended_err *) CMSG_DATA(cmsg);
+                 cu->cu_error.re_errno = e->ee_errno;
+                 return (cu->cu_error.re_status = RPC_CANTRECV);
+               }
++        free (cbuf);
+       }
+ #endif
+       do
+Index: git/ChangeLog
+===================================================================
+--- git.orig/ChangeLog
++++ git/ChangeLog
+@@ -1,3 +1,10 @@
++2016-05-23  Florian Weimer  <fweimer@redhat.com>
++
++   CVE-2016-4429
++   [BZ #20112]
++   * sunrpc/clnt_udp.c (clntudp_call): Use malloc/free for the error
++   payload.
++
+ 2016-04-29  Florian Weimer  <fweimer@redhat.com>
+    [BZ #20010]
index 44923797d68aed8ee0fb913042ec5ad82f1d32c4..b71018b25b25ed7b080593969466d238aa46fcad 100644 (file)
@@ -37,6 +37,7 @@ SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
            file://0025-eglibc-Forward-port-cross-locale-generation-support.patch \
            file://0026-When-disabling-SSE-make-sure-fpmath-is-not-set-to-us.patch \
            file://CVE-2016-3706.patch \
+           file://CVE-2016-4429.patch \
 "
 
 SRC_URI += "\