]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: add libexec and traceevent to packages
authorBruce Ashfield <bruce.ashfield@windriver.com>
Wed, 12 Mar 2014 20:30:40 +0000 (20:30 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Mar 2014 12:05:29 +0000 (12:05 +0000)
Recent versions of perf may install files into /usr/libexec/perf-core and in
/usr/lib/traceevent. To avoid packaging QA errors, we add these two
directories to the FILES variables.

We also add: INHIBIT_PACKAGE_DEBUG_SPLIT="1" to avoid the following issue
(due to a trailing / being removed):

   ERROR: debugedit failed with exit code 256
   ...
   debugedit: canonicalization unexpectedly shrank by one character

And finally, we must ensure that the traceevent libraries are installed to
the proper multilib library path. If building some multlibs, the incorrect
library path will be selected by perf, since it triggers via: ifeq
($(ARCH),x86_64) (or similiar mechanism per arch).

In a 32 bit build, with a 64 bit multilib, the arch won't match and the
detection of a 64 bit build (and library) are not exected. To ensure that
libraries are installed to the correct location, we can make the substitution
in the config/Makefile. For non multilib builds, this has no impact.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 56576d5d657fb8446146540d7e38547c2b4b21cb..9dfccdfd60750fe160736e5e5c3b6d3783b96dbc 100644 (file)
@@ -120,6 +120,19 @@ do_install() {
 do_configure_prepend () {
     #kernels before 3.1 do not support WERROR env variable
     sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile
+    if [ -e "${S}/tools/perf/config/Makefile" ]; then
+        sed -i 's,-Werror ,,' ${S}/tools/perf/config/Makefile
+    fi
+
+    # If building a multlib based perf, the incorrect library path will be
+    # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
+    # build, with a 64 bit multilib, the arch won't match and the detection of a 
+    # 64 bit build (and library) are not exected. To ensure that libraries are
+    # installed to the correct location, we can make the substitution in the 
+    # config/Makefile. For non multilib builds, this has no impact.
+    if [ -e "${S}/tools/perf/config/Makefile" ]; then
+        sed -i 's,libdir = $(prefix)/$(lib),libdir = $(prefix)/${baselib},' ${S}/tools/perf/config/Makefile
+    fi
 }
 
 python do_package_prepend() {
@@ -128,6 +141,8 @@ python do_package_prepend() {
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-FILES_${PN} += "${libexecdir}/perf-core"
+FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent"
 FILES_${PN}-dbg += "${libdir}/python*/site-packages/.debug"
 FILES_${PN} += "${libdir}/python*/site-packages"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT="1"