]> code.ossystems Code Review - openembedded-core.git/commitdiff
libsolv: enable rpm support
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Fri, 30 Dec 2016 15:59:17 +0000 (17:59 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 13 Mar 2017 09:43:21 +0000 (09:43 +0000)
This is required by libdnf.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
meta/recipes-extended/libsolv/libsolv_0.6.26.bb

index d46fca8e2415965844fce767d83207428348b000..c90f5834f5ba6bfd82862cce58e81a572561cf93 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "devel"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
 
-DEPENDS = "expat zlib"
+DEPENDS = "expat zlib rpm"
 
 SRC_URI = "git://github.com/openSUSE/libsolv.git \
           "
@@ -18,7 +18,7 @@ S = "${WORKDIR}/git"
 
 inherit cmake
 
-EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON"
+EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON -DENABLE_RPMMD=ON -DENABLE_RPMDB=ON"
 
 PACKAGES =+ "${PN}-tools ${PN}ext"