]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-files: Check for /run and /var/lock softlinks on upgrade
authorBryan Evenson <bevenson@melinkcorp.com>
Tue, 14 Apr 2015 21:08:15 +0000 (17:08 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 20 Apr 2015 14:02:52 +0000 (15:02 +0100)
Commit ea647cd9eebdc3e3121b84074519c4bb305adac9 moved the locations
of /run and /var/lock to match the FHS 3 draft specifications.
However, the install doesn't remove the existing directories.
As a result, upgrading a system may result in /run as a softlink
to /var/run and /var/run as a softlink to /run, creating a circular
link.

During pre-install, check for the existence of the old softlinks and
remove them so the new directories can be installed.

Signed-off-by: Bryan Evenson <bevenson@melinkcorp.com>
meta/recipes-core/base-files/base-files_3.0.14.bb

index f2d254e6bdf637f1d301c811471e3c8ad9d5f7a8..e16fe722b8a5710c313c0c5ed90aadc2a060ef69 100644 (file)
@@ -69,6 +69,29 @@ hostname = "${MACHINE}"
 
 BASEFILESISSUEINSTALL ?= "do_install_basefilesissue"
 
+# In previous versions of base-files, /run was a softlink to /var/run and the
+# directory was located in /var/volatlie/run.  Also, /var/lock was a softlink
+# to /var/volatile/lock which is where the real directory was located.  Now,
+# /run and /run/lock are the real directories.  If we are upgrading, we may
+# need to remove the symbolic links first before we create the directories.
+# Otherwise the directory creation will fail and we will have circular symbolic
+# links.
+# 
+pkg_preinst_${PN} () {
+    #!/bin/sh -e
+    if [ x"$D" = "x" ]; then
+        if [ -h "/var/lock" ]; then
+            # Remove the symbolic link
+            rm -f /var/lock
+        fi
+
+        if [ -h "/run" ]; then
+            # Remove the symbolic link
+            rm -f /run
+        fi
+    fi     
+}
+
 do_install () {
        for d in ${dirs755}; do
                install -m 0755 -d ${D}$d
@@ -82,6 +105,7 @@ do_install () {
        for d in ${volatiles}; do
                ln -sf volatile/$d ${D}${localstatedir}/$d
        done
+
        ln -snf ../run ${D}${localstatedir}/run
        ln -snf ../run/lock ${D}${localstatedir}/lock