]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: fix tmpfiles location when multilib in use
authorReinette Chatre <reinette.chatre@intel.com>
Wed, 23 Sep 2015 20:49:37 +0000 (13:49 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Sep 2015 16:53:24 +0000 (17:53 +0100)
Systemd's configuration files for creation, deletion and cleaning
of volatile and temporary files are installed in /usr/lib even when
multilib is in use (when /usr/lib64 is available). In this check the
systemd.conf file will not be found if libdir is /usr/lib64 so we fix the
path to match this file's installation path to look for it in
${exec_prefix}/lib

Signed-off-by: Reinette Chatre <reinette.chatre@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_225.bb

index fd1a3f315a3ac444658f7d6bbeda96c31f793d72..ef8d297e0219d5025af68eb679278733f248fd33 100644 (file)
@@ -189,8 +189,8 @@ do_install() {
        sed -i -e 's/.*ForwardToSyslog.*/ForwardToSyslog=yes/' ${D}${sysconfdir}/systemd/journald.conf
        # this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
        # for existence else it fails
-       if [ -s ${D}${libdir}/tmpfiles.d/systemd.conf ]; then
-               ${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
+       if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ]; then
+               ${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf', d)}
        fi
        install -Dm 0755 ${S}/src/systemctl/systemd-sysv-install.SKELETON ${D}${systemd_unitdir}/systemd-sysv-install
 }