]> code.ossystems Code Review - openembedded-core.git/commitdiff
ca-certificates: avoid using += with an over-ride
authorAndre McCurdy <armccurdy@gmail.com>
Fri, 6 Jul 2018 05:07:02 +0000 (22:07 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jul 2018 21:54:56 +0000 (22:54 +0100)
Using += with an over-ride can be a source of confusion so try to
avoid the construct in core recipes.

In this case, the commit which added the over-ride seems to have been
buggy - the commit message mentions "add to SYSROOT_DIRS" rather than
a correct description of what the change actually did, ie "over-ride
SYSROOT_DIRS":

  http://git.openembedded.org/openembedded-core/commit/?id=355e49e19abb3e729c82a6de46ada8da8a257f58

The commit also appears to have been unnecessary as ${sysconfdir} is
appended to SYSROOT_DIRS for -native recipes by default from within
staging.bbclass.

To workaround the bug introduced by the first commit, a subsequent
commit later added ${datadir}/ca-certificates to the over-ride value
(which would not normally be necessary as ${datadir} is included in
the default value of SYSROOT_DIRS - ie the value which was lost due
to being over-ridden):

  http://git.openembedded.org/openembedded-core/commit/?id=09bb7718d74573be9a5db4d0737fb14126f6489c

Therefore the fix seem to be to remove the SYSROOT_DIRS over-ride
entirely - the default value of SYSROOT_DIRS set by staging.bbclass
includes both ${datadir} and ${sysconfdir} when building for -native.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/ca-certificates/ca-certificates_20170717.bb

index 350294858befed93cbbeadfcaa626e6c98842da1..24d3a6e4d3e86e7b1b714e5fba8ad0ebb2794c60 100644 (file)
@@ -26,7 +26,6 @@ SRC_URI = "git://salsa.debian.org/debian/ca-certificates.git;protocol=https \
            "
 
 S = "${WORKDIR}/git"
-SYSROOT_DIRS_class-native += "${sysconfdir} ${datadir}/ca-certificates"
 
 inherit allarch