]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub: add -Wno-error=trampolines to native CFLAGS
authorBill Randle <william.c.randle@intel.com>
Fri, 18 Mar 2016 18:16:27 +0000 (11:16 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 20 Mar 2016 22:57:59 +0000 (22:57 +0000)
(Resend as mailer munged previous submission. Also updated comments
to indicate problem is not limited to gcc 5.3.0.)

Adds -Wno-error=trampolines to native CFLAGS prevent multiple compile
errors when using gentoo builf of gcc.

[YOCTO #9201]

Signed-off-by: Bill Randle <william.c.randle@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-bsp/grub/grub-efi_2.00.bb

index 4e80e1815ea96c5da6826b6a965608c6349c1ba1..dbc034ce541ff10f485f6528bd86106619bcb4d8 100644 (file)
@@ -35,6 +35,10 @@ EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
 
 EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
 
+# ldm.c:114:7: error: trampoline generated for nested function 'hook' [-Werror=trampolines]
+# and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
+CFLAGS_append_class-native = " -Wno-error=trampolines"
+
 do_install_class-native() {
        install -d ${D}${bindir}
        install -m 755 grub-mkimage ${D}${bindir}