]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpmresolve: fix reporting of multiple matches error
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Wed, 3 Oct 2012 12:37:16 +0000 (13:37 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Oct 2012 12:45:03 +0000 (13:45 +0100)
We were mistakenly writing what was meant to go to stderr into the
output file, so when the "Multiple matches" error showed we weren't
actually seeing the matches printed.

Also change the wording of the "Unable to find package..." to "Unable
to resolve package..." instead so that it makes more sense if it is
printed after the "Multiple matches" error.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpmresolve/rpmresolve.c
meta/recipes-devtools/rpm/rpmresolve_1.0.bb

index 3613ee5a8d6fc5db53527e730ee61854c7bb1c15..4e9d055f24db2c8a1711f5ff3eed4e099e49bae7 100644 (file)
@@ -185,7 +185,7 @@ int processPackages(rpmts *ts, int tscount, const char *packagelistfn, int ignor
                                 char *value = NULL;
                                 rc = getPackageStr(ts[i], keys[keyindex], RPMTAG_PACKAGEORIGIN, &value);
                                 if(rc == 0)
-                                    fprintf(outf, "  %s\n", value);
+                                    fprintf(stderr, "  %s\n", value);
                                 else
                                     fprintf(stderr, "  (%s)\n", keys[keyindex]);
                             }
@@ -197,10 +197,10 @@ int processPackages(rpmts *ts, int tscount, const char *packagelistfn, int ignor
 
                 if( !found ) {
                     if( ignoremissing ) {
-                        fprintf(stderr, "unable to find package %s - ignoring\n", line);
+                        fprintf(stderr, "Unable to resolve package %s - ignoring\n", line);
                     }
                     else {
-                        fprintf(stderr, "unable to find package %s\n", line);
+                        fprintf(stderr, "Unable to resolve package %s\n", line);
                         missing = 1;
                     }
                 }
index 3ce4369d0c6f639b9c1b9308f8fadd93c8e5c680..ea542e1cc3e5531f8ec6309146790f29e2972f90 100644 (file)
@@ -4,7 +4,7 @@ DESCRIPTION = "OpenEmbedded RPM resolver - performs RPM database lookups in batc
 DEPENDS = "rpm"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "file://rpmresolve.c"