]> code.ossystems Code Review - openembedded-core.git/commitdiff
libx11: fix build error
authorMaxin B. John <maxin.john@intel.com>
Tue, 11 Jul 2017 12:58:12 +0000 (15:58 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Jul 2017 12:48:56 +0000 (13:48 +0100)
libx11 build fails with this error:

fatal error: bits/long-double-64.h: No such file or directory
| compilation terminated.

This is due to the fact that "makekeys" should be compiled for the host
since it is executed at build time to generate ks_tables.h. Since we have
the X11 include files in the standard path of oe-core, we can remove the
X11_CFLAGS from Makefile.

Signed-off-by: Maxin B. John <maxin.john@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/xorg-lib/libx11_1.6.5.bb

index 71cbf67a0af9dd4731f602b3a3741539373b7aa1..50e8837b98913b6675a73fff33f2683b0c722e05 100644 (file)
@@ -5,6 +5,9 @@ BBCLASSEXTEND = "native nativesdk"
 
 SRC_URI += "file://disable_tests.patch \
            "
+do_configure_append () {
+    sed -i -e "/X11_CFLAGS/d" ${B}/src/util/Makefile
+}
 
 SRC_URI[md5sum] = "0f618db70c4054ca67cee0cc156a4255"
 SRC_URI[sha256sum] = "4d3890db2ba225ba8c55ca63c6409c1ebb078a2806de59fb16342768ae63435d"