]> code.ossystems Code Review - openembedded-core.git/commitdiff
shadow: use 'users' group by default
authorOtavio Salvador <otavio@ossystems.com.br>
Mon, 23 Jul 2012 17:37:17 +0000 (14:37 -0300)
committerScott Garman <scott.a.garman@intel.com>
Wed, 8 Aug 2012 18:10:48 +0000 (11:10 -0700)
The rootfs has 'users' group at number 100 and without this fix it
would assign to a non-existent group and if a group with gid as 1000
is created later it would own all files for users created.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Reworked commit to fix merge conflicts with denzil branch.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-extended/shadow/shadow_4.1.4.3.bb

index f892eb93a0166ee2b92f1875e2beaaf2637f18e3..38cc0059bbf8a77fd97fc38938822cb9332bc322 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
 
 DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 RDEPENDS_${PN} = "shadow-securetty ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_PLUGINS}', '', d)}"
-PR = "r8"
+PR = "r9"
 
 SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
            file://login_defs_pam.sed \
@@ -83,6 +83,9 @@ do_install_append() {
        sed -i 's:/bin/bash:/bin/sh:g' ${D}${sysconfdir}/default/useradd
        sed -i '/^CREATE_MAIL_SPOOL/ s:^:#:' ${D}${sysconfdir}/default/useradd
 
+       # Use users group by default
+       sed -i 's,^GROUP=1000,GROUP=100,g' ${D}${sysconfdir}/default/useradd
+
        install -d ${D}${sbindir} ${D}${base_sbindir} ${D}${base_bindir} 
        for i in passwd chfn newgrp chsh groups ; do
                mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}