]> code.ossystems Code Review - openembedded-core.git/commitdiff
distcc: use PACKAGECONFIG for x11 distro feature
authorChristopher Larson <chris_larson@mentor.com>
Fri, 6 Apr 2012 20:59:08 +0000 (15:59 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 May 2012 14:00:24 +0000 (15:00 +0100)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
meta/recipes-devtools/distcc/distcc_2.18.3.bb

index ec6ffb37fa18bfb9eda4e3210e39fc2c2dfbdb01..de181e5e87e47c0823453985efb10d84d54b411c 100644 (file)
@@ -4,11 +4,15 @@ compilation of C/C++/ObjC code across machines on a network."
 SECTION = "devel"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r7"
+PR = "r8"
 
-DEPENDS = "avahi ${GTKDEP}"
-GTKDEP_libc-uclibc = ""
-GTKDEP = "gtk+"
+DEPENDS = "avahi"
+
+GTKCONFIG = "gtk"
+GTKCONFIG_libc-uclibc = ""
+
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', '${GTKCONFIG}', '', d)}"
+PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
 
 RRECOMMENDS_${PN} = "avahi-daemon"
 
@@ -28,8 +32,6 @@ inherit autotools pkgconfig update-rc.d
 
 INITSCRIPT_NAME = "distcc"
 
-EXTRA_OECONF = "--with-gtk"
-EXTRA_OECONF_libc-uclibc = "--without-gtk --without-gnome"
 do_install_append() {
     install -d ${D}${sysconfdir}/init.d/
     install -d ${D}${sysconfdir}/default