]> code.ossystems Code Review - openembedded-core.git/commitdiff
qt4: fix debug symbol stripping
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Tue, 6 Dec 2011 16:51:00 +0000 (16:51 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 8 Dec 2011 15:14:05 +0000 (15:14 +0000)
Adds a patch imported from Debian to not strip the executables as part
of the Qt build process. This fixes the warnings shown at packaging
stage as well as the content of the debug symbol packages.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
meta/recipes-qt/qt4/files/add_nostrip_for_debug_packages.diff [new file with mode: 0644]
meta/recipes-qt/qt4/qt-4.7.4.inc
meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb

diff --git a/meta/recipes-qt/qt4/files/add_nostrip_for_debug_packages.diff b/meta/recipes-qt/qt4/files/add_nostrip_for_debug_packages.diff
new file mode 100644 (file)
index 0000000..774cb99
--- /dev/null
@@ -0,0 +1,23 @@
+author: Fathi Boudra <fabo@debian.org>
+
+Qt is built in release mode and strip files by default.
+Set CONFIG+=nostrip to avoid the stripping and
+let dh_strip do it to generate debug packages.
+
+Upstream-Status: Inappropriate [Configuration]
+
+---
+ configure |    2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/configure
++++ b/configure
+@@ -627,6 +627,8 @@ mkdir -p "$outpath/config.tests"
+ rm -f "$outpath/config.tests/.qmake.cache"
+ cp "$QMAKE_VARS_FILE" "$outpath/config.tests/.qmake.cache"
++QMakeVar add CONFIG nostrip
++
+ QMakeVar add styles "cde mac motif plastique cleanlooks windows"
+ QMakeVar add decorations "default windows styled"
+ QMakeVar add mouse-drivers "pc"
index bc33b6b1b87db5d8f8b77edc4417e736c1fdc7e9..7a3ba54cc8bccb2ea8f95f9bba41ddbad8489dd1 100644 (file)
@@ -14,6 +14,7 @@ SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.
            file://0001-Added-Openembedded-crossarch-option.patch \
            file://blacklist-diginotar-certs.diff \
            file://fix-translations.patch \
+           file://add_nostrip_for_debug_packages.diff \
            file://g++.conf \
            file://linux.conf \
            file://fix-qtbug-20925.patch \
index e34ec8d5db85d95b2b84b1db3e8e45b4eab877d3..6b9f97a356080e3c9b4c8bf3658c463c5ec57a70 100644 (file)
@@ -1,7 +1,7 @@
 require qt-${PV}.inc
 require qt4-embedded.inc
 
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
 
 QT_CONFIG_FLAGS_append_armv6-vfp = " -no-neon "
 
index 8c489362d7f187166c2f4a7f1aaf7d7d39920633..0db090f8e050d68a73da641ddce379bc65a04f1f 100644 (file)
@@ -1,7 +1,7 @@
 require qt4-x11-free.inc
 require qt-${PV}.inc
 
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
 
 QT_CONFIG_FLAGS_append_armv6-vfp = " -no-neon "