]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot: remove do_install from u-boot.inc
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 1 Mar 2011 17:32:55 +0000 (12:32 -0500)
committerSaul Wold <sgw@linux.intel.com>
Wed, 2 Mar 2011 17:48:50 +0000 (09:48 -0800)
Fixes [BUGID #777]

The do_install rule in u-boot.inc was installing a host
tool into the target ${bindir}, which is subsequently
stripped with target strip during packaging, and the
obvious error ensues.

The native u-boot recipe has its own install rule, and
the machine specific u-boot doesn't require mkimage or
anything else in the do_install function. So we remove
it completely until it is needed again.

[sgw: PR bump]
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-bsp/uboot/u-boot.inc
meta/recipes-bsp/uboot/u-boot_git.bb

index 1457c042e8d33c76f763916e08d9cee9222192ef..d1cebeedfb9d3d9abbc2df7441d7665a250ab723 100644 (file)
@@ -31,8 +31,3 @@ do_deploy () {
        ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
 }
 addtask deploy before do_build after do_compile
-
-do_install() {
-       install -d ${D}${bindir}
-       install -m 755 tools/mkimage ${D}${bindir}/
-}
index b3207c68b0b92b4692f2929f58d31b5291c3c4de..4686a5875b00dff63ee80620349dbe2194690f20 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-git/${MACHINE}"
 
 PV = "v2010.12+${PR}+git${SRCPV}"
-PR="r0"
+PR="r1"
 
 SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"