]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcroco: Convert to use autotools_stage
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:59:39 +0000 (15:59 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:59:39 +0000 (15:59 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/libcroco/libcroco_0.6.1.bb

index 6ac74e48ac08a2c167347c0f76b48b14ae7fcd17..6534fdab3e28acbbddcc5839ab61b961fd38d16d 100644 (file)
@@ -2,15 +2,8 @@ DESCRIPTION = "The Libcroco project is an effort to build a generic Cascading St
 SECTION = "x11/utils"
 DEPENDS = "glib-2.0 libxml2 zlib"
 LICENSE = "LGPL"
-PR = "r2"
+PR = "r3"
 
-inherit autotools pkgconfig gnome
+inherit autotools_stage pkgconfig gnome
 
 SRC_URI_append = " file://croco.patch;patch=1 "
-
-do_stage() {
-        install -d ${STAGING_LIBDIR}
-        install -d ${STAGING_INCDIR}/libcroco
-        install -m 644 src/*.h ${STAGING_INCDIR}/libcroco/
-        install -m 755 src/.libs/*so* ${STAGING_LIBDIR}/
-}