]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/5.10: features/nft_tables: refresh config options
authorBruce Ashfield <bruce.ashfield@gmail.com>
Sun, 27 Jun 2021 16:50:39 +0000 (12:50 -0400)
committerAnuj Mittal <anuj.mittal@intel.com>
Wed, 30 Jun 2021 06:04:16 +0000 (14:04 +0800)
The nft tables feature had become out of sync with current config
options. Refreshing the support with the following commits:

Integrating the following commit(s) to linux-yocto/.:

    da478fab290 nft: add CONFIG_NFT_SOCKET
    54e2d36b291 nft: add CONFIG_NFT_TUNNEL
    6fefc38049a nft: add CONFIG_NFT_CONNLIMIT
    cb0b5fc7ed5 nft: enable NF_TABLES_NETDEV
    d36b304d614 nft: drop rbtree
    0a70fa87ee0 nft: merge chain nat types
    c226e82038a nft: merge route type to core
    79968ab78bb nft: masq options merged
    8a0bff8cc5f nft: _set is now built-ins
    5952a26c4f7 nft: consolidate _set options
    0941f794363 nf: META is now builtin
    2fcc2c1b552 nf: EXTHDR is part of core, drop config
    e909f08155d nf: ARP is bool, set to y
    3bc18ee0615 nf: make nf_tables =y
    b90241a5403 nf: set CONFIG_NF_TABLES_IPV6, since dependencies are =y
    32ae602ab4d nf: set CONFIG_NF_TABLES_IPV4, since dependencies are =y
    2a9be72daea nf: make inet_tables =y

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit cce1ed5973455666c09dd56ecf3d0c373bdb3fb2)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
meta/recipes-kernel/linux/linux-yocto_5.10.bb

index 30dbb5d8322b6ff94a87b1410a7ce9f975079219..ea2c854649bf056a468898223405fd80a857e50b 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "74f60bcd7323d243e0f3d3db34021ae624afb61a"
-SRCREV_meta ?= "4a59bc57b2be77da9394b10eb37067da7d63b7a4"
+SRCREV_meta ?= "b969f83647833d21d8826c4667492f58895213c3"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
index 33339f5ca1594b54feecad888ffd3892b34ee838..d73b1d030536c6cdd846b292abc0b51485f0c304 100644 (file)
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine_qemuarm ?= "20eb193a68fbdaa56ed9a49b97aef6a0eb9fbdea"
 SRCREV_machine ?= "9fe9a613a93f7ff39c94e376a15d5fc3ec7a0640"
-SRCREV_meta ?= "2c3ec293dba693dc7a344d4e42cb7fa733ef4f2d"
+SRCREV_meta ?= "b969f83647833d21d8826c4667492f58895213c3"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 9d7690dcd14d5f54e85df47780d7b559e1f3e9a0..c3342da193dc97f2496572167f0b816b31a90e3c 100644 (file)
@@ -23,7 +23,7 @@ SRCREV_machine_qemux86 ?= "9fe9a613a93f7ff39c94e376a15d5fc3ec7a0640"
 SRCREV_machine_qemux86-64 ?= "9fe9a613a93f7ff39c94e376a15d5fc3ec7a0640"
 SRCREV_machine_qemumips64 ?= "7bc9a08bf3b92db4fdb0225fdd23836c8f5c037f"
 SRCREV_machine ?= "9fe9a613a93f7ff39c94e376a15d5fc3ec7a0640"
-SRCREV_meta ?= "2c3ec293dba693dc7a344d4e42cb7fa733ef4f2d"
+SRCREV_meta ?= "b969f83647833d21d8826c4667492f58895213c3"
 
 # remap qemuarm to qemuarma15 for the 5.8 kernel
 # KMACHINE_qemuarm ?= "qemuarma15"