]> code.ossystems Code Review - openembedded-core.git/commitdiff
libuser: Fix security string formatting issues.
authorAníbal Limón <anibal.limon@linux.intel.com>
Fri, 13 May 2016 19:49:26 +0000 (14:49 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 15 May 2016 08:04:19 +0000 (09:04 +0100)
[YOCTO #9547]

Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/libuser/libuser/0001-modules-files.c-parse_field-fix-string-formating-in-.patch [new file with mode: 0644]
meta/recipes-extended/libuser/libuser_0.62.bb

diff --git a/meta/recipes-extended/libuser/libuser/0001-modules-files.c-parse_field-fix-string-formating-in-.patch b/meta/recipes-extended/libuser/libuser/0001-modules-files.c-parse_field-fix-string-formating-in-.patch
new file mode 100644 (file)
index 0000000..074491b
--- /dev/null
@@ -0,0 +1,34 @@
+From a4857911ece5ebfcdef42aee4c070eb216f39597 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?An=C3=ADbal=20Lim=C3=B3n?= <anibal.limon@linux.intel.com>
+Date: Fri, 13 May 2016 11:40:13 -0500
+Subject: [PATCH] modules/files.c: parse_field fix string formating in
+ g_warnings
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+[YOCTO #9547]
+
+Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
+
+Upstream-status: Pending
+---
+ modules/files.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/modules/files.c b/modules/files.c
+index 4ef0a57..35eafc9 100644
+--- a/modules/files.c
++++ b/modules/files.c
+@@ -534,7 +534,7 @@ parse_field(const struct format_specifier *format, GValue *value,
+                                                string, &err);
+       if (ret == FALSE) {
+               g_assert(err != NULL);
+-              g_warning(lu_strerror(err));
++              g_warning(lu_strerror(err), NULL);
+               lu_error_free(&err);
+       }
+       return ret;
+-- 
+2.1.4
+
index 1369ae8f2d7a1d72483996510d9278afd03bbe1c..7a64efe558faa5b5dbd4a222d110310a8d9b050b 100644 (file)
@@ -14,7 +14,8 @@ SECTION = "base"
 SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz \
            file://0001-Check-for-issetugid.patch \
            file://0002-remove-unused-execinfo.h.patch \
-          "
+           file://0001-modules-files.c-parse_field-fix-string-formating-in-.patch \
+           "
 
 SRC_URI[md5sum] = "63e5e5c551e99dc5302b40b80bd6d4f2"
 SRC_URI[sha256sum] = "a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b"