]> code.ossystems Code Review - openembedded-core.git/commitdiff
lz4: update to r127
authorArmin Kuster <akuster808@gmail.com>
Fri, 2 Jan 2015 04:45:28 +0000 (20:45 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 16 Jan 2015 22:59:44 +0000 (22:59 +0000)
dropped Makefile from license check.

r127
added : lz4frame_static.h

r126
New : lz4frame API is now integrated into liblz4
Fixed : GCC 4.9 bug on highest performance settings, reported by Greg Slazinski
Fixed : bug within LZ4 HC streaming mode, reported by James Boyle
Fixed : older compiler don't like nameless unions, reported by Cheyi Lin
Changed : lz4 is C90 compatible
Changed : added -pedantic option, fixed a few minor warnings

r125
New 32/64 bits, little/big endian and strict/efficient align detection routines
(internal)
New directory structure
Small decompression speed improvement
Fixed a bug into LZ4_compress_limitedOutput(), thanks to Christopher Speller
lz4 utility uses lz4frame library (lz4io modified)

r124
New : LZ4 HC streaming mode
Fixed : LZ4F_compressBound() using null preferencesPtr

Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/lz4/lz4_svn.bb

index 3a742000b194e4cd78f91a82096d1918d5313fac..363e439eea1106945467d853e7c2bb1250c544a6 100644 (file)
@@ -2,11 +2,10 @@ SUMMARY = "Extremely Fast Compression algorithm"
 DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
 
 LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0b0d063f37a4477b54af2459477dcafd \
-                    file://Makefile;md5=7551cc5d31ca66e003ab06e83486524a"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0b0d063f37a4477b54af2459477dcafd"
 
 # Upstream names releases after SVN revs
-SRCREV = "123"
+SRCREV = "127"
 PV = "r${SRCREV}"
 
 SRC_URI = "svn://lz4.googlecode.com/svn/;module=trunk;protocol=http"