]> code.ossystems Code Review - openembedded-core.git/commitdiff
bluez-utils: Add patch to allow disabling of hal in configure
authorRichard Purdie <richard@openedhand.com>
Mon, 15 Oct 2007 10:21:02 +0000 (10:21 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 15 Oct 2007 10:21:02 +0000 (10:21 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2875 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/bluez/bluez-utils/allow-no-hal.patch [new file with mode: 0644]
meta/packages/bluez/bluez-utils_3.18.bb

diff --git a/meta/packages/bluez/bluez-utils/allow-no-hal.patch b/meta/packages/bluez/bluez-utils/allow-no-hal.patch
new file mode 100644 (file)
index 0000000..3350c80
--- /dev/null
@@ -0,0 +1,26 @@
+---
+ configure.in |   11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+Index: bluez-utils-3.18/configure.in
+===================================================================
+--- bluez-utils-3.18.orig/configure.in 2007-09-02 17:40:57.000000000 +0100
++++ bluez-utils-3.18/configure.in      2007-10-15 11:45:01.000000000 +0100
+@@ -31,7 +31,16 @@ AC_PATH_ALSA
+ AC_PATH_GSTREAMER
+ AC_PATH_OPENOBEX
+ AC_PATH_OPENSYNC
+-AC_PATH_HAL
++
++AC_DEFUN([AC_PATH_HAL], [
++      PKG_CHECK_MODULES(HAL, hal >= 0.5.8, hal_found=yes, hal_found=no)
++])
++
++AC_SUBST(HAL_CFLAGS)
++AC_SUBST(HAL_LIBS)
++
++AM_CONDITIONAL(HAL, test "${hal_enable}" = "yes" && test "${hal_found}" = "yes")
++
+ AC_PATH_USB
+ AC_PATH_EXPAT
+ AC_PATH_INOTIFY
index 3de342fa80d6d9c124a0920d2a380849effaa8e2..50004e3cb200b49736c6df847b59fe0c7b9d8aa7 100644 (file)
@@ -1,11 +1,13 @@
 require bluez-utils.inc
 
 DEPENDS += "glib-2.0"
-PR = "r2"
+PR = "r3"
 
 # ti patch doesn't apply, people using it should rediff it and send it upstream
 #SRC_URI += "file://hciattach-ti-bts.patch;patch=1 "
 
+SRC_URI += "file://allow-no-hal.patch;patch=1 "
+
 EXTRA_OECONF = " \
                  --enable-bccmd \
                 --enable-hid2hci \